1. 程式人生 > >PAT 1151 LCA in a Binary Tree (30)

PAT 1151 LCA in a Binary Tree (30)

1151 LCA in a Binary Tree (30) (30 分)

The lowest common ancestor (LCA) of two nodes U and V in a tree is the deepest node that has both U and V as descendants.

Given any two nodes in a binary tree, you are supposed to find their LCA.

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers: M (≤ 1,000), the number of pairs of nodes to be tested; and N (≤ 10,000), the number of keys in the binary tree, respectively. In each of the following two lines, N distinct integers are given as the inorder and preorder traversal sequences of the binary tree, respectively. It is guaranteed that the binary tree can be uniquely determined by the input sequences. Then M lines follow, each contains a pair of integer keys U and V. All the keys are in the range of int

.

Output Specification:

For each given pair of U and V, print in a line LCA of U and V is A. if the LCA is found and A is the key. But if A is one of U and V, print X is an ancestor of Y. where X is A and Y is the other node. If U or V is not found in the binary tree, print in a line ERROR: U is not found.

or ERROR: V is not found. or ERROR: U and V are not found..

Sample Input:

6 8
7 2 3 4 6 5 1 8
5 3 7 2 6 4 8 1
2 6
8 1
7 9
12 -3
0 8
99 99

Sample Output:

LCA of 2 and 6 is 3.
8 is an ancestor of 1.
ERROR: 9 is not found.
ERROR: 12 and -3 are not found.
ERROR: 0 is not found.
ERROR: 99 and 99 are not found.

思路:

不需要特地弄個樹形結構然後建樹,可以直接根據先序遍歷和中序遍歷得出每個節點的父節點和深度。需要注意的是測試的資料不是按照樣例這樣說8個節點然後編號就是1-8,很有可能有奇怪的數字,我一開始只用陣列就出現了一個段錯誤,後來全改成map又發現超時,所以需要自己手動編個號。

程式碼:

#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <cmath>
#include <cctype>
#include <climits>
#include <iostream>
#include <algorithm>
#include <string>
#include <vector>
#include <queue>
#include <stack>
#include <map>  
#include <set>
using namespace std;

map<int, int> mp1, mp2;     //mp1-節點權值轉手動編號 mp2-手動編號轉權值
int pre[10005], in[10005];  //pre-先序遍歷 in-中序遍歷
int f[10005], d[10005];     //f-父節點 d-深度

void build(int* pre, int* in, int len, int father, int depth)
{
	if (len == 0)
		return;
	int i = 0;
	while (pre[0] != in[i])
		i++;
	build(pre + 1, in, i, pre[0], depth + 1);
	build(pre + i + 1, in + i + 1, len - i - 1, pre[0], depth + 1);
	f[mp1[pre[0]]] = mp1[father];
	d[mp1[pre[0]]] = depth;
}

int LCA(int a, int b)
{
	if (d[a] > d[b])
		swap(a, b);
	while (d[b] > d[a])
		b = f[b];
	while (a != b)
	{
		a = f[a];
		b = f[b];
	}
	return a;
}

int main()
{
	int m, n;
	scanf("%d%d", &m, &n);
	for (int i = 0; i < n; i++)
	{
		scanf("%d", &in[i]);
		mp1[in[i]] = i + 1;
		mp2[i + 1] = in[i];
	}
	for (int i = 0; i < n; i++)
		scanf("%d", &pre[i]);
	build(pre, in, n, pre[0], 1);
	for (int i = 0; i < m; i++)
	{
		int a, b, cnt = 0;
		scanf("%d%d", &a, &b);
		if (mp1[a] == 0 && mp1[b] == 0)
			printf("ERROR: %d and %d are not found.\n", a, b);
		else if (mp1[a] == 0)
			printf("ERROR: %d is not found.\n", a);
		else if (mp1[b] == 0)
			printf("ERROR: %d is not found.\n", b);
		else
		{
			int ans = LCA(mp1[a], mp1[b]);
			if (mp2[ans] == a)
				printf("%d is an ancestor of %d.\n", a, b);
			else if (mp2[ans] == b)
				printf("%d is an ancestor of %d.\n", b, a);
			else
				printf("LCA of %d and %d is %d.\n", a, b, mp2[ans]);
		}
	}
	return 0;
}