1. 程式人生 > >1031 Hello World for U (20 分)(其實這個題目有更簡單的方法)

1031 Hello World for U (20 分)(其實這個題目有更簡單的方法)

Given any string of N (≥5) characters, you are asked to form the characters into the shape of U. For example, helloworld can be printed as:

h  d
e  l
l  r
lowo

That is, the characters must be printed in the original order, starting top-down from the left vertical line with n​1​​ characters, then left to right along the bottom line with n​2​​ characters, and finally bottom-up along the vertical line with n​3​​ characters. And more, we would like U

 to be as squared as possible -- that is, it must be satisfied that n​1​​=n​3​​=max { k | k≤n​2​​ for all 3≤n​2​​≤N } with n​1​​+n​2​​+n​3​​−2=N.

Input Specification:

Each input file contains one test case. Each case contains one string with no less than 5 and no more than 80 characters in a line. The string contains no white space.

Output Specification:

For each test case, print the input string in the shape of U as specified in the description.

Sample Input:

helloworld!

Sample Output:

h   !
e   d
l   l
lowor

 AC程式碼:

#include <iostream>
#include <vector>
#include <map>
#include <algorithm>
#include <cmath>
#include <set>
#include <cstdio>
#include <cstdlib>
#include <cstring>
using namespace std;

int main()
{
    char str[85];
    scanf("%s",str);
    int len = strlen(str);
    //printf("%d\n",len);
    int j;
    for(int i=len; i>=1; i--)
    {
        if(len-i*2+2-i>=0&&len-i*2+2-i<=2)///行數小於等於列數,但是儘可能的接近。
        {///多找幾個樣例找找規律就好。沒有什麼可以講解的。
            j = i;
            break;
        }
    }
    int k = len-j*2+2;
    //printf("%d %d\n",j,k);
    for(int i=0; i<j; i++)
    {
        for(int l=0; l<k; l++)
        {
            if(i<j-1)
            {
                if(l==0)
                    printf("%c",str[i]);
                else if(l==k-1)
                    printf("%c",str[len-i-1]);
                else printf(" ");
            }
            else
            {
                printf("%c",str[i+l]);
            }
        }
        printf("\n");
    }
    return 0;
}