1. 程式人生 > >pat甲級 1065(資料範圍)

pat甲級 1065(資料範圍)

1065 A+B and C (64bit) (20 分)

Given three integers A, B and C in [−2​63​​,2​63​​], you are supposed to tell whether A+B>C.

Input Specification:

The first line of the input gives the positive number of test cases, T (≤10). Then T test cases follow, each consists of a single line containing three integers A, B and C, separated by single spaces.

Output Specification:

For each test case, output in one line Case #X: true if A+B>C, or Case #X: false otherwise, where X is the case number (starting from 1).

Sample Input:

3
1 2 3
2 3 4
9223372036854775807 -9223372036854775808 0

Sample Output:

Case #1: false
Case #2: true
Case #3: false

心得:要先求出res,在判斷是否越界(有點坑)。

#include<iostream>
#include<cstdio>
#include<cstdlib>
using namespace std;
typedef long long LL;
int main(void)
{
	LL a,b,c,res;
	int t,i;
	scanf("%d",&t);
	for(i=1;i<=t;i++)
	{
		scanf("%lld %lld %lld",&a,&b,&c);
		res=a+b;
		printf("Case #%d: ",i);
		if(a>0&&b>0&&res<0)
		{
			printf("true\n");
		}
		else if(a<0&&b<0&&res>=0)
		{
			printf("false\n");
		}
		else if(res>c) printf("true\n");
		else printf("false\n");
	}
	return 0;
}