1. 程式人生 > >求n^k得前三位和後三位(Leading and Trailing)

求n^k得前三位和後三位(Leading and Trailing)

You are given two integers: n and k, your task is to find the most significant three digits, and least significant three digits of nk.

Input

Input starts with an integer T (≤ 1000), denoting the number of test cases.

Each case starts with a line containing two integers: n (2 ≤ n < 231) and k (1 ≤ k ≤ 107)

.

Output

For each case, print the case number and the three leading digits (most significant) and three trailing digits (least significant). You can assume that the input is given such that nkcontains at least six digits.

Sample Input

5

123456 1

123456 2

2 31

2 32

29 8751919

Sample Output

Case 1: 123 456

Case 2: 152 936

Case 3: 214 648

Case 4: 429 296

Case 5: 665 669

後三位求法:直接快速冪模1000即可;

前三位求法:記      d = a + b = {log_{10}}^{n}; a為d的整數部分,b為小數部分.

則 n = 10^{a}*10^{b};  即10^{b} = n/10^{a};    則10^{b+2}為前三位

#include <iostream>
#include <cstdio>
#include <cstring>
#include <cmath>
using namespace std;
typedef long long ll;
ll mul(ll a, ll b, int mod)
{
    ll res = 1;
    while(b)
    {
        if(b&1)
            res = (res*a)%mod;
        a = (a*a)%mod;
        b >>= 1;
    }
    return res;
}

int main()
{
    int T,cnt = 1;
    scanf("%d",&T);
    while(T--)
    {
        ll n,k;
        scanf("%lld %lld",&n,&k);
        int temp2 = (int)mul(n,k,1000);
        double t = k*log10(n);
        int temp1 = pow(10,t-(int)t)*100;
        printf("Case %d: %d %03d\n",cnt++,temp1,temp2);
    }
    return 0;
}