1. 程式人生 > >6231 K-th Number

6231 K-th Number

Alice are given an array A[1..N]A[1..N] with NN numbers.  Now Alice want to build an array BB by a parameter KK as following rules:  Initially, the array B is empty. Consider each interval in array A. If the length of this interval is less than KK, then ignore this interval. Otherwise, find the KK-th largest number in this interval and add this number into array BB.  In fact Alice doesn't care each element in the array B. She only wants to know the MM-th largest element in the array BB. Please help her to find this number.

Input

The first line is the number of test cases.  For each test case, the first line contains three positive numbers N(1≤N≤105),K(1≤K≤N),MN(1≤N≤105),K(1≤K≤N),M. The second line contains NN numbers Ai(1≤Ai≤109)Ai(1≤Ai≤109).  It's guaranteed that M is not greater than the length of the array B. 

Output

For each test case, output a single line containing the MM-th largest element in the array BB.

Sample Input

2
5 3 2
2 3 1 5 4
3 3 1
5 8 2

Sample Output

3
2

給你一個數組A 在每個可行的連續區間裡找到第K大的數放入陣列B,然後從陣列B裡找到第M大的數。

反過來思考,這個數就是在陣列A裡,作為第K大的數的時候的區間數為M。然後就可以二分了。統計區間個數用到了尺取法。

AC程式碼:

#include <cstdio>
#include <cstring>
#include <iostream>

using namespace std;

typedef long long LL;

int N,K;
LL M;

int a[100010];

bool judge(int x)
{
    LL ans=0;
    int num=0;
    int j=1;

    for(int i=1;i<=N;i++)
    {
        if(a[i]>=x)
            num++;
        if(num==K)
        {
            ans+=N-i+1;
            while(a[j]<x)
            {
                ans+=N-i+1;
                j++;
            }
            num--;
            j++;
        }
    }

    if(ans>=M)
        return true;
    return false;
}

int main()
{
    int t;
    cin>>t;
    while(t--)
    {
        cin>>N>>K>>M;
        for(int i=1;i<=N;i++)
            cin>>a[i];

        int l=1,r=1000000000;
        int mid;
        while(l<r)
        {
            mid=(l+r)/2;
            if(judge(mid))
                l=mid+1;
            else
                r=mid;
        }
        cout<<l-1<<endl;
    }
}