1. 程式人生 > >2015ACM/ICPC亞洲區瀋陽站-——Pagodas(簡單博弈)

2015ACM/ICPC亞洲區瀋陽站-——Pagodas(簡單博弈)

nn pagodas were standing erect in Hong Jue Si between the Niushou Mountain and the Yuntai Mountain, labelled from 11 to nn. However, only two of them (labelled aa and bb, where 1≤a≠b≤n1≤a≠b≤n) withstood the test of time.  Two monks, Yuwgna and Iaka, decide to make glories great again. They take turns to build pagodas and Yuwgna takes first. For each turn, one can rebuild a new pagodas labelled i (i∉{a,b} and 1≤i≤n)i (i∉{a,b} and 1≤i≤n) if there exist two pagodas standing erect, labelled jj and kkrespectively, such that i=j+ki=j+k or i=j−ki=j−k. Each pagoda can not be rebuilt twice.  This is a game for them. The monk who can not rebuild a new pagoda will lose the game.

Input

The first line contains an integer t (1≤t≤500)t (1≤t≤500) which is the number of test cases.  For each test case, the first line provides the positive integer n (2≤n≤20000)n (2≤n≤20000) and two different integers aa and bb.

Output

For each test case, output the winner (``Yuwgna" or ``Iaka"). Both of them will make the best possible decision each time.

Sample Input

16
2 1 2
3 1 3
67 1 2
100 1 2
8 6 8
9 6 8
10 6 8
11 6 8
12 6 8
13 6 8
14 6 8
15 6 8
16 6 8
1314 6 8
1994 1 13
1994 7 12

Sample Output

Case #1: Iaka
Case #2: Yuwgna
Case #3: Yuwgna
Case #4: Iaka
Case #5: Iaka
Case #6: Iaka
Case #7: Yuwgna
Case #8: Yuwgna
Case #9: Iaka
Case #10: Iaka
Case #11: Yuwgna
Case #12: Yuwgna
Case #13: Iaka
Case #14: Yuwgna
Case #15: Iaka
Case #16: Iaka

解題思路:

      試過兩組資料後,可以很清楚看到:最左邊的一個可修建位置一定是gcd(a,b) !!! 並且所有能修建的點都一定是這個gcd的整數倍。那麼....總共能修建ans =  n/gcd(a,b)次,  根據奇偶性,奇數先手的Yuwgna獲勝。

#include<bits/stdc++.h>
using namespace std;
int main(void)
{
     int T;cin>>T;
     int cas = 0; 
     while(T--)
     {
        int n,a,b; 
        cin>>n>>a>>b;
        int gc = __gcd(a,b); 
        int tot = n/gc;    
     	printf(tot&1 ?"Case #%d: Yuwgna\n":"Case #%d: Iaka\n",++cas);   
     }
}