1. 程式人生 > >SDUT-3330 順序表應用6:有序順序表查詢

SDUT-3330 順序表應用6:有序順序表查詢

Problem Description 順序表內按照由小到大的次序存放著n個互不相同的整數,任意輸入一個整數,判斷該整數在順序表中是否存在。如果在順序表中存在該整數,輸出其在表中的序號;否則輸出“No Found!"。 Input 第一行輸入整數n (1 <= n <= 100000),表示順序表的元素個數; 第二行依次輸入n個各不相同的有序非負整數,代表表裡的元素; 第三行輸入整數t (1 <= t <= 100000),代表要查詢的次數; 第四行依次輸入t個非負整數,代表每次要查詢的數值。 保證所有輸入的數都在 int 範圍內。 Output 輸出t行,代表t次查詢的結果,如果找到在本行輸出該元素在表中的位置,否則本行輸出No Found! Sample Input 10 1 22 33 55 63 70 74 79 80 87 4 55 10 2 87 Sample Output 4 No Found! No Found! 10  

#include <stdio.h>
#include <stdlib.h>
struct node
{
    int * h;
    int len;
    int size;
}list;
int f(int l, int r, int x)
{
    if(l == r)
    {
        if(list.h[l] == x)return l;
        else return -1;
    }
    int mid = (l + r) / 2;
    if(list.h[mid] < x)
        return f(mid + 1, r, x);
        else return f(l, mid, x);
}
int main()
{
    int n, i, t, x, w;
    scanf("%d", &n);
    list.h = (int *)malloc((n + 5) * sizeof(int));
    list.len = n + 5;
    list.size = (n + 5) * 4;
    for(i = 1; i <= n; i++)
    {
        scanf("%d", &list.h[i]);
    }
    scanf("%d", &t);
    while(t--)
    {
        scanf("%d", &x);
        w = f(1, n, x);
        if(w == -1)
        {
            printf("No Found!\n");
        }
        else
        {
            printf("%d\n", w);
        }
    }
    return 0;
}