1. 程式人生 > >(PAT)1147Heaps(判斷是大頂堆還是小頂堆)

(PAT)1147Heaps(判斷是大頂堆還是小頂堆)

In computer science, a heap is a specialized tree-based data structure that satisfies the heap property: if P is a parent node of C, then the key (the value) of P is either greater than or equal to (in a max heap) or less than or equal to (in a min heap) the key of C. A common implementation of a heap is the binary heap, in which the tree is a complete binary tree. (Quoted from Wikipedia at 

https://en.wikipedia.org/wiki/Heap_(data_structure))

Your job is to tell if a given complete binary tree is a heap.

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers: M (≤ 100), the number of trees to be tested; and N (1 < N ≤ 1,000), the number of keys in each tree, respectively. Then M lines follow, each contains N distinct integer keys (all in the range of int

), which gives the level order traversal sequence of a complete binary tree.

Output Specification:

For each given tree, print in a line Max Heap if it is a max heap, or Min Heap for a min heap, or Not Heap if it is not a heap at all. Then in the next line print the tree's postorder traversal sequence. All the numbers are separated by a space, and there must no extra space at the beginning or the end of the line.

Sample Input:

3 8
98 72 86 60 65 12 23 50
8 38 25 58 52 82 70 60
10 28 15 12 34 9 8 56

Sample Output:

Max Heap
50 60 65 72 12 23 86 98
Min Heap
60 58 52 38 82 70 25 8
Not Heap
56 12 34 28 9 8 15 10

解題思路,給出一堆數列,判斷是大頂堆,小頂堆還不是堆

我解這道題的初步思路是,利用堆的下調演算法,依次對每個結點進行判斷,如果結點與左子或右子比較有違背小頂堆或大頂堆的性質

(如在小頂堆中,一個結點大於其子節點),這個序列就不是小頂堆或者大頂堆

#include<iostream>
#include <algorithm>
using namespace std;
const int maxn = 1010;
const int manco = 101;
int nheap[manco][maxn];
bool ismax = true, ismin = true;

void isMaxHeap(int a[],int pos,int n) {
	int current = pos;
	int onechild = pos * 2;
	
	if (onechild <= n) {
		if (onechild + 1 <= n && a[onechild] < a[onechild + 1]) {  //左子小於右子的話
			onechild = onechild + 1;
		}
		if (a[current] >= a[onechild]) {
			isMaxHeap(a,onechild, n);       //右子遞迴尋找
			isMaxHeap(a,onechild - 1, n);   //左子遞迴尋找
		}
		else {
			ismax = false;
		}
	}
}

void isMinHeap(int a[],int pos, int n) {
	int current = pos;
	int onechild = pos * 2;

	if (onechild <= n) {
		if (onechild + 1 <= n && a[onechild] > a[onechild + 1]) {  //左子小於右子的話
			onechild = onechild + 1;
		}
		if (a[current] <= a[onechild]) {
			isMinHeap(a,onechild, n);  //左子遞迴尋找
			isMinHeap(a,onechild-1, n);      //右子遞迴尋找
		}
		else {
			ismin = false;
		}
	}
}

void postOrd(int a[],int node,int size) {
	if (node * 2 <= size) {
		postOrd(a,node * 2,size);
	}
	if (node * 2 + 1 <= size) {
		postOrd(a,node * 2 + 1,size);
	}

	if (node == 1) {
		cout << a[node];
	}
	else {
		cout << a[node] << " ";
	}
}

int main() {

	int n, m;
	cin >> n >> m;
	for (int i = 1; i <= n; ++i) {
		for (int j = 1; j <= m; ++j) {
			cin >> nheap[i][j];
		}
	}

	for (int i = 1; i <= n; ++i) {
		isMaxHeap(nheap[i], 1, m);
		if (ismax) {
			cout << "Max Heap" << endl;
			postOrd(nheap[i], 1, m);
			cout << endl;
			ismax = true;
			ismin = true;
			continue;
		}

		isMinHeap(nheap[i], 1, m);
		if (ismin) {
			cout << "Min Heap" << endl;
			postOrd(nheap[i], 1, m);
			cout << endl;
			ismax = true;
			ismin = true;
			continue;
		}
		
		cout << "Not Heap" << endl;
		postOrd(nheap[i], 1, m);
		cout << endl;
		ismax = true;
		ismin = true;
	}

	system("PAUSE");
	return 0;
}

上述程式碼用到了遞迴,所以5組資料只過了2組(剩下3組超時)

然後我換了一種思路,我們可以通過判斷頭結點和其子節點的大小關係初步得出這是小頂堆或是大頂堆的結論

然後判斷每一個結點是否違背小頂堆(或是大頂堆),如有違背,那麼這個序列不是堆

#include <iostream>
#include <algorithm>
using namespace std;

const int maxc = 101;
const int maxn = 1001;
int mmheap[maxc][maxn];

//後序遍歷
void postOrder(int a[],int root,int n) {
	if (root * 2 <= n) {
		postOrder(a, root * 2, n);
	}
	if (root * 2 + 1 <= n) {
		postOrder(a, root * 2 + 1, n);
	}

	if (root == 1) {
		cout << a[root];
	}
	else {
		cout << a[root] << " ";
	}
}


int main() {

	int n, m;
	cin >> n >> m;
	for (int i = 1; i <= n; ++i) {
		for (int j = 1; j <= m; ++j) {
			cin >> mmheap[i][j];
		}
	}

	for (int i = 1; i <= n; ++i) {
		int flag;
		flag = mmheap[i][1] > mmheap[i][2] ? 1 : -1;   //1是大頂堆,-1是小頂堆
		for (int j = 1; j <= m / 2; ++j) {
			int lchild = j * 2;
			int rchild = j * 2 + 1;
			if (flag == 1 && (mmheap[i][j] <= mmheap[i][lchild] || (rchild <= m && mmheap[i][j] <= mmheap[i][rchild])))
			{
				flag = 0;  //判斷得出這不是堆
			}
			if (flag == -1 && (mmheap[i][j] >= mmheap[i][lchild] || (rchild <= m && mmheap[i][j] >= mmheap[i][rchild])))
			{ 
				flag = 0;  //判斷得出這不是堆
			}
		}
		if (flag == 0) cout << "Not Heap" << endl;
		else if (flag == 1) cout << "Max Heap" << endl;
		else if (flag == -1) cout << "Min Heap" << endl;
		postOrder(mmheap[i], 1, m);
		cout << endl;
	}

	system("PAUSE");
	return 0;
}