1. 程式人生 > >Red and Black(板子)

Red and Black(板子)

題目描述

題面

There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can’t move on red tiles, he can move only on black tiles.
Write a program to count the number of black tiles which he can reach by repeating the moves described above.

Input

The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.

‘.’ - a black tile
‘#’ - a red tile
‘@’ - a man on a black tile(appears exactly once in a data set)
The end of the input is indicated by a line consisting of two zeros.

Output

For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).

Sample Input

6 9
…#.
…#





#@…#
.#…#.
11 9
.#…
.#.#######.
.#.#…#.
.#.#.###.#.
.#.#…@#.#.
.#.#####.#.
.#…#.
.#########.

11 6
…#…#…#…
…#…#…#…
…#…#…###
…#…#…#@.
…#…#…#…
…#…#…#…
7 7
…#.#…
…#.#…
###.###
…@…
###.###
…#.#…
…#.#…
0 0

Sample Output

45
59
6
13

程式碼

#include <cstdio>
#include<iostream>
#include<cstring>
#include<cstdlib>
#include <iomanip>
#include <queue>
#include <stack>
using namespace std;
const int dx[5]= {0,0,0,-1,1};
const int dy[5]= {0,1,-1,0,0};
char tu[105][105];
int ans=1;
int cx,cy;
bool vis[105][105];
int lie,hang;
void cuntu()
{
    for(int i=1; i<=hang; i++)
    {
        for(int j=1; j<=lie; j++)
        {
            char t=getchar();
            tu[i][j]=t;
            if(t=='@')
            {
                cx=i;
                cy=j;
            }
        }
        getchar();
    }
    return;
}
bool judge(int x,int y)
{
    if(x<1||y<1||x>hang||y>lie||vis[x][y]==1||tu[x][y]=='#')
        return false;
    return true;
}
void dfs(int a,int b)
{
    vis[a][b]=1;
    for(int i=1; i<=4; i++)
    {
        int tx=a+dx[i];
        int ty=b+dy[i];
        if(judge(tx,ty))
        {
            ans+=1;
            dfs(tx,ty);
        }
    }
    return;
}
int main()
{
    while(cin>>lie>>hang)
    {
        getchar();
        if(lie==0&&hang==0)
        {
            break;
        }
        else
        {
            memset(vis,0,sizeof(vis));
            memset(tu,0,sizeof(tu));
            ans=1;
            cuntu();
            dfs(cx,cy);
            cout<<ans<<endl;
            //tiaoshi
//            for(int i=1; i<=hang; i++)
//            {
//                for(int j=1; j<=lie; j++)
//                {
//                    cout<<tu[i][j]<<" ";
//                }
//                cout<<endl;
//            }
//            cout<<cx<<" "<<cy<<endl;
        }
    }
    return 0;
}

新手仍處於迷迷糊糊的狀態,註釋等我再想想