1. 程式人生 > >poj 2377 Bad Cowtractors (最大生成樹)

poj 2377 Bad Cowtractors (最大生成樹)

Bessie has been hired to build a cheap internet network among Farmer John's N (2 <= N <= 1,000) barns that are conveniently numbered 1..N. FJ has already done some surveying, and found M (1 <= M <= 20,000) possible connection routes between pairs of barns. Each possible connection route has an associated cost C (1 <= C <= 100,000). Farmer John wants to spend the least amount on connecting the network; he doesn't even want to pay Bessie. 

Realizing Farmer John will not pay her, Bessie decides to do the worst job possible. She must decide on a set of connections to install so that (i) the total cost of these connections is as large as possible, (ii) all the barns are connected together (so that it is possible to reach any barn from any other barn via a path of installed connections), and (iii) so that there are no cycles among the connections (which Farmer John would easily be able to detect). Conditions (ii) and (iii) ensure that the final set of connections will look like a "tree".

Input

* Line 1: Two space-separated integers: N and M 

* Lines 2..M+1: Each line contains three space-separated integers A, B, and C that describe a connection route between barns A and B of cost C.

Output

* Line 1: A single integer, containing the price of the most expensive tree connecting all the barns. If it is not possible to connect all the barns, output -1.

Sample Input

5 8
1 2 3
1 3 7
2 3 10
2 4 4
2 5 8
3 4 6
3 5 2
4 5 17

Sample Output

42

Hint

OUTPUT DETAILS: 

The most expensive tree has cost 17 + 8 + 10 + 7 = 42. It uses the following connections: 4 to 5, 2 to 5, 2 to 3, and 1 to 3.

題意:n個點,m條邊,求一個最大生成樹
注意輸出-1

最大生成樹就是最小生成樹中的排序函式改成從大到小排即可

#pragma GCC optimize(2)
#include<stdio.h>
#include<algorithm>
#include<iostream>
#include<string.h>
#include<set>
#include<vector>
#include<string>
#include<queue>
using namespace std;
const int maxn = 1500;
const int inf = 0x3f3f3f3f;
typedef long long ll;
struct node
{
	int u, v, w;
}edge[maxn*maxn];
int f[maxn];
int sum = 0;
int n, m;
bool cmp(node &a, node &b)
{
	return a.w > b.w;
}
int find(int x)
{
	if (x == f[x])
	{
		return x;
	}
	else
	{
		return f[x] = find(f[x]);
	}
}
int flag = 0;
void kru()
{
	int po = 0;
	for (int i = 0; i < m; i++)
	{
		int u = find(edge[i].u);
		int v = find(edge[i].v);
		if (u != v)
		{
			po++;
			sum += edge[i].w;
			f[u] = v;
			if (po == n - 1)
			{
				flag = 1;
				return;
			}
		}
	}
}
int main()
{
	//freopen("C://input.txt", "r", stdin);
	scanf("%d%d", &n, &m);
	for (int i = 1; i <= n; i++)
	{
		f[i] = i;
	}
	for (int i = 0;i < m; i++)
	{
		scanf("%d%d%d", &edge[i].u, &edge[i].v, &edge[i].w);
	}
	sort(edge, edge + m, cmp);
	kru();
	if (flag)
	{
		printf("%d\n", sum);
	}
	else
	{
		printf("-1\n");
	}
	return 0;
}