1. 程式人生 > >HDU 1056 HangOver (簡單數學題)

HDU 1056 HangOver (簡單數學題)

題意:

意思就是   你輸入一個長度,問你最少用幾張卡片能     讓伸出去的長度大於等於你輸入的長度.公式題目題目上面有
Problem Description How far can you make a stack of cards overhang a table? If you have one card, you can create a maximum overhang of half a card length. (We're assuming that the cards must be perpendicular to the table.) With two cards you can make the top card overhang the bottom one by half a card length, and the bottom one overhang the table by a third of a card length, for a total maximum overhang of 1/2 + 1/3 = 5/6 card lengths. In general you can make n cards overhang by 1/2 + 1/3 + 1/4 + ... + 1/(n + 1) card lengths, where the top card overhangs the second by 1/2, the second overhangs tha third by 1/3, the third overhangs the fourth by 1/4, etc., and the bottom card overhangs the table by 1/(n + 1). This is illustrated in the figure below.

 

The input consists of one or more test cases, followed by a line containing the number 0.00 that signals the end of the input. Each test case is a single line containing a positive floating-point number c whose value is at least 0.01 and at most 5.20; c will contain exactly three digits.

For each test case, output the minimum number of cards necessary to achieve an overhang of at least c card lengths. Use the exact output format shown in the examples.

Sample Input 1.00 3.71 0.04 5.19 0.00
Sample Output 3 card(s) 61 card(s) 1 card(s) 273 card(s)
#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
int main()
{
	double a,b;
	double temp;
	int i;
	while(cin>>a) {
		if(a-0<1e-5) break;
		for(i=2,temp=0;;i++) {
			temp+=(double)1/i;
			<span style="color:#ff0000;">if(temp-a>=0) </span>break;
		}
		cout<<i-1<<" card(s)"<<endl;
 	}
 	return 0;
}
wa點在紅色部分,等於號要取到。。。。。。。