1. 程式人生 > >HDU 1089.Ignatius's puzzle【數學題】【2016年1月2】

HDU 1089.Ignatius's puzzle【數學題】【2016年1月2】

Ignatius's puzzle

Problem Description Ignatius is poor at math,he falls across a puzzle problem,so he has no choice but to appeal to Eddy. this problem describes that:f(x)=5*x^13+13*x^5+k*a*x,input a nonegative integer k(k<10000),to find the minimal nonegative integer a,make the arbitrary integer x ,65|f(x)if
no exists that a,then print "no".


Input The input contains several test cases. Each test case consists of a nonegative integer k, More details in the Sample Input.

Output The output contains a string "no",if you can't find a,or you should output a line contains the a.More details in the Sample Output.

Sample Input 11 100 9999
Sample Output 22 no 43  題意很明確,只要符合題意的x存在就行,不妨令x=1,然後直接計算。程式碼如下:


#include<iostream>
using namespace std;
int main()
{
    int k;
    while(cin >> k)
    {
        int f[70] = {0};
        bool flag = false;
        for(int i = 1;; ++i)
        {
            if((i*k+18) % 65 == 0)
            {
                cout << i << endl;
                flag = true;
                break;
            }
            if(f[(i*k+18)%65]) break;//產生迴圈
            f[(i*k+18)%65] = 1;//標記
        }
        if(!flag) cout <<"no"<<endl;
    }
    return 0;
}