1. 程式人生 > >命運只負責洗牌,但玩牌的是我們自己。

命運只負責洗牌,但玩牌的是我們自己。

資料結構實驗之連結串列六:有序連結串列的建立
Time Limit: 1000 ms Memory Limit: 65536 KiB

Problem Description
輸入N個無序的整數,建立一個有序連結串列,連結串列中的結點按照數值非降序排列,輸出該有序連結串列。

Input
第一行輸入整數個數N;
第二行輸入N個無序的整數。

Output
依次輸出有序連結串列的結點值。

Sample Input
6
33 6 22 9 44 5

Sample Output
5 6 9 22 33 44

Hint
不得使用陣列!

提示:順序建連結串列時涉及排序,可用兩個while迴圈對連結串列進行排序

AC程式碼:

#include <stdio.h>
#include <stdlib.h>
typedef struct node
{
    int data;
    struct node *next;
} node;
int main()
{
    int n,x,t;
    node *head,*p,*q;
    head=(node *)malloc(sizeof(node));
    head->next=NULL;
    q=head;
    scanf("%d",&n);
    while(n--)//順序建連結串列
{ scanf("%d",&x); p=(node *)malloc(sizeof(node)); p->data=x; p->next=NULL; q->next=p; q=p; } q=head->next; while(q)//排序 { p=q->next; while(p) { if(p->data<q->data) { t=
p->data; p->data=q->data; q->data=t; } p=p->next; } q=q->next; } p=head->next; while(p) { if(p->next==NULL) printf("%d\n",p->data); else printf("%d ",p->data); p=p->next; } return 0; }

餘生還請多多指教!