1. 程式人生 > >【打CF,學演算法——三星級】CF Gym 100548K Last Denfence

【打CF,學演算法——三星級】CF Gym 100548K Last Denfence

題面:

 Last Defence
Description
    Given two integers A and B. Sequence S is defined as follow:
    • S0 = A
    • S1 = B
    • Si = |Si−1 − Si−2| for i ≥ 2
    Count the number of distinct numbers in S.
Input
    The first line of the input gives the number of test cases, T. T test cases follow. T is about
    100000.
    Each test case consists of one line - two space-separated integers A, B. (0 ≤ A, B ≤ 1018).
Output
    For each test case, output one line containing “Case #x: y”, where x is the test case
    number (starting from 1) and y is the number of distinct numbers in S.
Samples
Sample Input 

   2
  7 4
  3 5

Sample Output
Case #1: 6
Case #2: 5

解題:

    過程便是輾轉相減法,然而模擬這個過程會超時,改進為輾轉相除法。直接拿大的數除小的數,即需要減的次數,加到結果中,最後結果便是答案。

程式碼:

#include <iostream>
using namespace std;
int main()
{
	long long int a,b,n,ans,tmp;
	cin>>n;
	for(int i=1;i<=n;i++)
	{
	cout<<"Case #"<<i<<": ";
	  ans=0;
      cin>>a>>b;    
	  if(a==0&&b==0)
		 {
			 cout<<"1\n";
			 continue;
		 }
	   if(a==0||b==0)
		  {
			  cout<<"2\n";
			  continue;
		  }
	  while(b)
	  {
		  ans+=a/b;
		  tmp=b;
		  b=a%b;
		  a=tmp;
	  }
      cout<<ans+1<<endl;
	}
	return 0;
}