1. 程式人生 > >Cisco 2960交換機配置

Cisco 2960交換機配置

彈出 版本 pre mode 打印 協商 bind ntp服務 con

一、 基本操作

Switch(config)#hostname test01(交換機名稱)             //全局模式下修改交換機名稱
Switch(config)#enable secret  123456                 //全局模式下設置登陸特權加密密碼
Switch(config)#enable password 123456                  //全局模式下設置登陸特權非加密密碼
Switch#show vlan             //特權模式下查看Vlan信息
Switch#show interfaces fa0/1             //特權模式下查看端口信息
Switch#show version            //特權模式下查看交換機系統版本、型號、開機時間等等

配置telnet遠程登錄

Switch(config)#enable secret  123456          //全局模式下設置登陸特權加密密碼,telnet遠程登錄需要先設置特權登錄密碼
Switch(config)#line vty 0 4          //全局模式下進入虛擬線程配置模式, 0到4意思是最多同時允許0,1,2,3,4的5個用戶遠程telnet登錄
Switch(config-line)#password 654321        //設置登錄口令(遠程telnet登錄交換機密碼)
Switch(config-line)#login               //設置遠程telnet需要口令驗證#
Switch#show running-config            //特權模式下查看telnet配置情況
line vty 0 4
password 654321
login
Switch#write                   //特權模式下保存配置

二.設置交換機時間

標註:普通思科交換機一般不帶電池保存時間,交換機重啟後時鐘都會恢復到初始化時間,建議配置NTP服務。
特權模式下顯示交換機時間

Switch#show clock
特權模式下修改交換機時間
Switch#clock set 17:42:00 22 Mar 2017

三.配置Vlan

1.增加vlan

Switch#vlan database                    //特權模式下進入Vlan子模式
Switch(vlan)#vlan 10 name test01        //創建vlan並命名為test01
Switch(vlan)#exit                       //退出Vlan配置模式
Switch#show vlan                        //返回到特權模式下查看Vlan創建情況

2.刪除Vlan

Switch#vlan database                    //特權模式下進入Vlan子模式
Switch(vlan)#no vlan 10                 //刪除已創建好的Vlan
Switch#show vlan id 10                  //返回到特權模式下查看指定的Vlan創建情況

3.將端口劃入指定的Vlan

Switch(config)#interface fastEthernet 0/1             //全局模式下進入fa/01端口模式
Switch(config-if)#switchport access vlan 10           //將fa0/1端口劃分到Vlan 10
Switch(config-if)#switchport mode access              //fa0/1設置成靜態Vlan訪問模式
Switch(config-if)#no shutdown                         //激活fa0/1接口
Switch(config)#interface range fastEthernet 0/2-10             //全局模式下進入fa/02端口到fa0/10端口模式
Switch(config-if-range)#switchport access vlan 10              //將入fa/02端口到fa0/10端口劃分到Vlan10
Switch(config-if-range)#switchport mode access              //fa/02端口到fa0/10端口設置成靜態Vlan訪問模式
Switch(config-if-range)#no shutdown                //激活fa/02端口到fa0/10端口
Switch#show vlan id 10                  //返回到特權模式下查看指定的Vlan創建情況
Switch#write                             //特權模式下保存配置

4.將端口劃出指定的Vlan

Switch(config)#interface fastEthernet 0/1               //全局模式下進入fa/01端口模式  
Switch(config-if)#no switchport access vlan 10            //將fa0/1端口從Vlan 10劃出(把fa0/1端口從Vlan10刪除)
Switch(config)#interface range fastEthernet 0/2-10              //全局模式下進入fa/02端口到fa0/10端口模式
Switch(config-if-range)#no switchport access vlan 10            //把fa0/2端口和fa/10從Vlan 10劃出(把fa0/1端口從Vlan10刪除)
Switch#write                           //特權模式下保存配置

5.配置Vlan的IP地址及網關

Switch(config)#interface vlan 10               //全局模式下進入指定vlan 10
Switch(config-if)#ip address 192.168.10.1 255.255.255.0             //配置vlan 10的IP地址及子網掩碼
Switch(config)#ip domain-name test.com            //全局模式下設置交換機所連域的域名test.com
Switch(config-if)#no shutdown                 //激活端口
Switch(config)#ip default-gateway 192.168.10.254         //全局模式下設置網關地址
Switch#show ip interface brief                  //特權模式下查看vlan及接口狀態
Switch#show running-config             //特權模式下查看交換機網關地址
Switch#write                   //特權模式下保存配置

四、交換機端口工作模式

1.三種工作模式

access     一個access端口只能屬於一個Vlan,也只能轉發這個Vlan數據,主要用於接入終端設備、如PC、服務器、打印服務器等
trunk     一個trunk端口屬於多個Vlan,能轉發多個Vlan數據,主要用於連接其它交換機、以便在線路上承載多個Vlan
dynamic   動態可取模式,主動對端協商,也就是通常的Trunk模式優先。在可以和對端協商成trunk模式時使用trunk模式,不行則改為access模式。
Switch(config)#interface fastEthernet 0/1            //全局模式下進入fa/01模式
Switch(config-if)#switchport mode ?                     //查看交換機支持哪些端口工作模式
access Set trunking mode to ACCESS unconditionally 
dynamic Set trunking mode to dynamically negotiate access or trunk mode 
trunk Set trunking mode to TRUNK unconditionally
Switch(config-if)#switchport mode access             //將fa0/1端口設置成Access模式
Switch(config-if)#switchport mode dynamic                //將fa0/1端口設置成Trunk模式
Switch(config-if)#switchport mode trunk            //將fa0/1端口設置成Trunk模式
Switch#show interfaces fastEthernet 0/1 switchport       //特權模式下查看端口工作模式
Name: Fa0/1
Switchport: Enabled
Administrative Mode: trunk
Operational Mode: down#
Switch#write                  //特權模式下保存配置

2.雙工模式設置

Switch(config)#interface fastEthernet 0/1                //全局模式下進入fa0/1端口
Switch(config-if)#duplex full                                 //自行選擇,full全雙工模式、half半雙工模式、auto自動選擇模式
Switch#show interfaces fastEthernet 0/1                   //查看fa0/1端口雙工模式
Encapsulation ARPA, loopback not set
Keepalive set (10 sec)
Full-duplex, 100Mb/s
Switch#write                                //保存配置

3.恢復交換機出廠設置

Switch#write erase                  //特權模式下執行出廠恢復設置,彈出提示按回車鍵確認
Switch#reload                         //特權模式下重啟交換機,彈出提示按回車鍵確認
## 4.使用IPSG綁定IP地址(Port/IP/MAC三者綁定)
Switch# show ip source binding                   //在特權模式下查看Port/IP/MAC綁定情況
Switch# show ip source binding | include 192.168.10.10                 //在特權模式下查看192.168.10.10 的Port/IP/MAC綁定情況
Switch# show arp | include 192.168.10.10               //特殊模式下查看192.168.10.10 的IP地址對應的物理地址與所屬於VLAN
Switch#show mac address-table | include 448a.5b00.12a1            //特殊模式下查看448a.5b00.12a1 的MAC地址對應的端口
Switch(config)# ip source binding 448a.5b00.12a1 vlan 192.168.10.10 interface GI0/12              //全局模式下綁定IP地址(Port/IP/MAC三者綁定)

4.交換機配置trunk端口

標註:(trunk允許多個Vlan通過,access只允許一個Vlan通過),三層交換機與二層交換機設置級連,三層交換端口默認dyna auto,dyna auto端口能同步下級交換機端口工作模式trunk,三層交換機會自動適應成trunk,所以,只要配置二層交換機端口為trunk即可。

Switch(config)#interface fastEthernet 0/24            //全局模式下進入fa0/24端口進行配置
Switch(config-if)#switchport mode trunk              //設置trunk口,允許多個 Vlan通過,一般接到三層交換機上的trunk口
Switch(config-if)#no shutdown                        //激活端口
Switch#write                                         //特權模式下保存配置
Switch#show interfaces fastEthernet 0/24 switchport         //查看fa0/24接口否配置成trunk
Name: Fa0/24
Switchport: Enabled
Administrative Mode: trunk

Cisco 2960交換機配置