1. 程式人生 > >poj 3259 Wormholes(判斷負環)

poj 3259 Wormholes(判斷負環)

Wormholes
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 44782 Accepted: 16496

Description

While exploring his many farms, Farmer John has discovered a number of amazing wormholes. A wormhole is very peculiar because it is a one-way path that delivers you to its destination at a time that is BEFORE you entered the wormhole! Each of FJ's farms comprises N

 (1 ≤ N ≤ 500) fields conveniently numbered 1..NM (1 ≤ M ≤ 2500) paths, and W (1 ≤ W ≤ 200) wormholes.

As FJ is an avid time-traveling fan, he wants to do the following: start at some field, travel through some paths and wormholes, and return to the starting field a time before his initial departure. Perhaps he will be able to meet himself :) .

To help FJ find out whether this is possible or not, he will supply you with complete maps to F (1 ≤ F ≤ 5) of his farms. No paths will take longer than 10,000 seconds to travel and no wormhole can bring FJ back in time by more than 10,000 seconds.

Input

Line 1: A single integer, FF farm descriptions follow. 
Line 1 of each farm: Three space-separated integers respectively: N
M, and W 
Lines 2..M+1 of each farm: Three space-separated numbers (SET) that describe, respectively: a bidirectional path between S and E that requires T seconds to traverse. Two fields might be connected by more than one path. 
Lines M+2..M+W+1 of each farm: Three space-separated numbers (SET) that describe, respectively: A one way path from S to E that also moves the traveler back T seconds.

Output

Lines 1..F: For each farm, output "YES" if FJ can achieve his goal, otherwise output "NO" (do not include the quotes).

Sample Input

2
3 3 1
1 2 2
1 3 4
2 3 1
3 1 3
3 2 1
1 2 3
2 3 4
3 1 8

Sample Output

NO
YES

Hint

For farm 1, FJ cannot travel back in time. 
For farm 2, FJ could travel back in time by the cycle 1->2->3->1, arriving back at his starting location 1 second before he leaves. He could start from anywhere on the cycle to accomplish this.

Source

題意:

有n個點,m條普通的雙向的路,w條單向的蟲洞,問是否能從某個點出發走一些路再回來時回到過去。

即判斷是否有負環。

這題的資料很弱,一開始用spfa去判斷與點1連通的路中是否有負環,按理應該是wa....結果過了....

題中並沒說是連通圖,可能與1不連通的一些點也能產生負環。

如果用spfa去判斷非連通圖中是否有負環應該遍歷每個頂點去判斷是否有負環, 這樣複雜度比較高。

但是Bellman-Ford可以避開這問題,因為Bellman-Ford是去拿每一條邊鬆弛,而spfa只是用與原點連通的邊去鬆弛。

spfa程式碼:

//C++ TLE, G++ 1000+ms
#include<queue>
#include<cstring>
#include<iostream>
#include<cstdio>
using namespace std;
const int maxn = 50005;
const int INF = 0x3f3f3f3f;
int n, m, w, k, head[maxn], dis[maxn], cnt[maxn];
bool book[maxn];

struct node
{
    int v, w, next;
}edge[maxn];

void addEdge(int u, int v, int w)
{
    edge[k].v = v;
    edge[k].w = w;
    edge[k].next = head[u];
    head[u] = k;
    k++;
}

bool spfa(int u)
{
    memset(book, 0, sizeof(book));
    memset(cnt, 0, sizeof(cnt));
    for(int i = 1; i <= n; i++) dis[i] = INF;
    dis[u] = 0;
    cnt[u]++;
    queue<int> q;
    q.push(u);
    while(!q.empty())
    {
        u = q.front(); q.pop();
        book[u] = 0;
        for(int i = head[u]; i != -1; i = edge[i].next)
        {
            int v = edge[i].v, w = edge[i].w;
            if(dis[u]+w < dis[v])
            {
                dis[v] = dis[u]+w;
                if(!book[v])
                {
                    book[v] = 1;
                    q.push(v);
                    cnt[v]++;
                    if(cnt[v] >= n) return 1;
                }
            }
        }
    }
    return 0;
}

int main(void)
{
    int t;
    cin >> t;
    while(t--)
    {
        memset(head, -1, sizeof(head));
        k = 0;
        scanf("%d%d%d", &n, &m, &w);
        for(int i = 1; i <= m+w; i++)
        {
            int u, v, w;
            scanf("%d%d%d", &u, &v, &w);
            if(i > m) w = -w;
            addEdge(u, v, w);
            if(i <= m) addEdge(v, u, w);
        }
        bool flag = 0;
        for(int i = 1; i <= n; i++)
        {
            if(spfa(i))
            {
                flag = 1;
                break;
            }
        }
        puts(flag ? "YES" : "NO");
    }
    return 0;
}


Bellman-Ford程式碼:

//47ms
#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
const int INF = 0x3f3f3f3f;
const int maxn = 50005;
int n, w, m, k, dis[maxn];
struct node
{
    int u, v, w;
    node() {}
    node(int uu, int vv, int ww): u(uu), v(vv), w(ww) {}
}edge[maxn];

bool Bellman_Ford(int s)
{
    for(int i = 1; i <= n; i++) dis[i] = INF;
    dis[s] = 0;
    for(int i = 0; i < n; i++)
    {
        int flag = 1;
        for(int j = 0; j < k; j++)
        {
            int u = edge[j].u;
            int v = edge[j].v;
            int w = edge[j].w;
            if(dis[u]+w < dis[v])
            {
                flag = 0;
                dis[v] = dis[u]+w;
                if(i == n-1) return true;
            }
        }
        if(flag) return false;
    }
    return false;
}

int main(void)
{
    int t;
    cin >> t;
    while(t--)
    {
        k = 0;
        scanf("%d%d%d", &n, &m, &w);
        for(int i = 1; i <= m+w; i++)
        {
            int u, v, w;
            scanf("%d%d%d", &u, &v, &w);
            if(i <= m)
            {
                edge[k++] = node(u, v, w);
                edge[k++] = node(v, u, w);
            }
            else edge[k++] = node(u, v, -w);
        }
        puts(Bellman_Ford(1) ? "YES" : "NO");
    }
    return 0;
}