1. 程式人生 > >HDU 1005 Number Sequence【迴圈節(取模)】

HDU 1005 Number Sequence【迴圈節(取模)】

Number Sequence

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 158149    Accepted Submission(s): 38735

Problem Description A number sequence is defined as follows:

f(1) = 1, f(2) = 1, f(n) = (A * f(n - 1) + B * f(n - 2)) mod 7.

Given A, B, and n, you are to calculate the value of f(n).

Input The input consists of multiple test cases. Each test case contains 3 integers A, B and n on a single line (1 <= A, B <= 1000, 1 <= n <= 100,000,000). Three zeros signal the end of input and this test case is not to be processed.

Output For each test case, print the value of f(n) on a single line.

Sample Input 1 1 3 1 2 10 0 0 0
Sample Output 2 5

  坑

AC程式碼:

#include<cstdio>

int a[111];
int main()
{
	int N,A,B; a[1]=a[2]=1; 
	while(~scanf("%d%d%d",&A,&B,&N),A|B|N) {
		if(N<3) {
			printf("1\n"); continue;
		}
		if(A%7==0&&B%7==0) {
	        printf(N>2?"0\n":"1\n"); continue; 
		}
		int T;
		for(int i=3;i<100;++i) {
			a[i]=(A*a[i-1]+B*a[i-2])%7;
			if(a[i-1]==1&&a[i]==1) {
				T=i-1-1; break; 
			} 
		}
		N%=T;
		if(!N) printf("%d\n",a[T]);
		else printf("%d\n",a[N]);
	} 
	return 0;
}