1. 程式人生 > >PAT A1063——set的常見用法詳解

PAT A1063——set的常見用法詳解

style height osi rip define lan alc sample from

1063 Set Similarity

Given two sets of integers, the similarity of the sets is defined to be N?c??/N?t??×100%, where N?c?? is the number of distinct common numbers shared by the two sets, and N?t?? is the total number of distinct numbers in the two sets. Your job is to calculate the similarity of any given pair of sets.

Input Specification:

Each input file contains one test case. Each case first gives a positive integer N (50) which is the total number of sets. Then N lines follow, each gives a set with a positive M (10?4??) and followed by M integers in the range [0,10?9??]. After the input of sets, a positive integer K (2000) is given, followed by K lines of queries. Each query gives a pair of set numbers (the sets are numbered from 1 to N). All the numbers in a line are separated by a space.

Output Specification:

For each query, print in one line the similarity of the sets, in the percentage form accurate up to 1 decimal place.

Sample Input:

3
3 99 87 101
4 87 101 5 87
7 99 101 18 5 135 18 99
2
1 2
1 3

Sample Output:

50.0%
33.3%

題意:
  給出N個集合,給出的集合中可能含有相同的值。然後要求M個查詢,每個查詢給出兩個集合的編號X和Y,求集合X和集合Y的相同元素率,即兩個集合的交集和並集(均需去重)的元素個數的比率
參考代碼:
#include<cstdio>
#include<set>
using namespace std;
const int N = 51;
set<int> st[N]; //N個集合
void compare(int x, int y) { //比較集合st[x]和集合st[y]
int totalNum = st[y].size(), sameNum = 0; //不同數的個數,相同數個個數
//遍歷集合st[x]
for(set<int>::iterator it = st[x].begin(); it != st[x].end(); it++) {
if(st[y].find(*it) != st[y].end()) sameNum++; //在st[y]中找到相同該元素
else totalNum++; //在st[y]中找不到相同元素
}
printf("%.1f%%\n", 100 * (double)sameNum/totalNum); //輸出比率
}

int main(){
int n,k,q,v,st1,st2;
scanf("%d", &n); //集合個數
for(int i = 1; i <= n; i++) {
scanf("%d", &k); //集合i中的元素個數
for(int j = 0; j < k; j++) {
scanf("%d", &v); //集合i中的元素v
st[i].insert(v); //將元素v加入集合st[i]中
}
}
scanf("%d", &q); //q個查詢
for(int i = 0; i < q; i++) {
scanf("%d%d", &st1, &st2); //欲對比的集合編號
compare(st1, st2); //比較兩個集合
}
return 0;
}

PAT A1063——set的常見用法詳解