1. 程式人生 > >Strange fuction 二分/三分求函式極值點

Strange fuction 二分/三分求函式極值點

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 4527    Accepted Submission(s): 3251


Problem Description Now, here is a fuction:
  F(x) = 6 * x^7+8*x^6+7*x^3+5*x^2-y*x (0 <= x <=100)
Can you find the minimum value when x is between 0 and 100.
Input The first line of the input contains an integer T(1<=T<=100) which means the number of test cases. Then T lines follow, each line has only one real numbers Y.(0 < Y <1e10)
Output Just the minimum value (accurate up to 4 decimal places),when x is between 0 and 100.
Sample Input 2 100 200
Sample Output -74.4291 -178.8534

這是一個開口向上的函式,我們只要求這個函式的極(最)小值即可,可以三分直接求,當然也可以先把函式求導,然後二分求解,水題...附上兩種解法吐舌頭

//三分求極值
#include <cmath>
#include <cstdio>
#include <string>
#include <cstring>
#include <iostream>
#include <algorithm>
const double INF = 0x7fffffff;
const double eps = 1e-10;
int T;
double Y,X;
double Calc(double x) { return 6*pow(x,7)+8*pow(x,6)+7*pow(x,3)+5*pow(x,2)-Y*x; }
void Search() {
    double l,r,mid,Rmid,MVal,RMVal;
    l = 0;r = 100;
    while(r-l>=eps)
    {
        mid = (l+r)/2.0;Rmid = (mid+r)/2.0;
        MVal = Calc(mid);RMVal = Calc(Rmid);
        if(MVal < RMVal)
        {
            r = Rmid;
        }
        else if(MVal > RMVal)
        {
            l = mid;
        }
        else
        {
            r = mid;
            l = Rmid;
        }
    }
    printf("%.4lf\n",Calc(mid));
}
int main() {
    //freopen("input.in","r",stdin);
    for(scanf("%d",&T);T--;)
    {
        scanf("%lf",&Y);
        Search();
    }
    return 0;
}


//二分求極值
#include <cmath>
#include <cstdio>
#include <string>
#include <cstring>
#include <iostream>
#include <algorithm>
const double INF = 0x7fffffff;
const double eps = 1e-10;
int T;
double Y,X;
double Calc(double x) { return 42*pow(x,6)+48*pow(x,5)+21*pow(x,2)+10*pow(x,1)-Y; }
double F(double x) { return 6*pow(x,7)+8*pow(x,6)+7*pow(x,3)+5*pow(x,2)-Y*x; }
void Search(){
    double l,r,mid,MVal;
    l = 0;r = 100;
    while(r-l>=eps)
    {
        mid = (l+r)/2.0;
        MVal = Calc(mid);
        if(MVal > 0)
        {
            r = mid;
        }
        else if(MVal < 0)
        {
            l = mid;
        }
        else break;
    }
    printf("%.4lf\n",F(mid));
}
int main() {
   // freopen("input.in","r",stdin);
    for(scanf("%d",&T);T--;)
    {
        scanf("%lf",&Y);
        Search();
    }
    return 0;
}