1. 程式人生 > >2016年杭電1008

2016年杭電1008

 Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 60547    Accepted Submission(s): 33223


Problem Description The highest building in our city has only one elevator. A request list is made up with N positive numbers. The numbers denote at which floors the elevator will stop, in specified order. It costs 6 seconds to move the elevator up one floor, and 4 seconds to move down one floor. The elevator will stay for 5 seconds at each stop.

For a given request list, you are to compute the total time spent to fulfill the requests on the list. The elevator is on the 0th floor at the beginning and does not have to return to the ground floor when the requests are fulfilled.

Input There are multiple test cases. Each case contains a positive integer N, followed by N positive numbers. All the numbers in the input are less than 100. A test case with N = 0 denotes the end of input. This test case is not to be processed.

Output Print the total time on a single line for each test case.

Sample Input 1 2 3 2 3 1 0
Sample Output 17 41題意:有一架電梯,上一層樓需要6秒,下一層樓需要4秒,到達指定樓層後停留5秒,假設每次開始時電梯都停留在第0層。輸入一個正整數N,表示電梯要停留N次,輸入每次要停留的樓層,輸出電梯按照指定的順序走完全程需要花費的時間。
#include <iostream>

using namespace std;

int main()
{
    int D;
    while(cin>>D)
    {
        if(D==0){
            break;
        }
        else{
            int a[D+1];
            a[0]=0;
            int i=1,sum=0;
            while(D--){
                cin>>a[i];
                i++;
            }
            for(int j=0;j<i-1;j++)
            {
                if(a[j+1]>a[j]){
                    sum=sum+(a[j+1]-a[j])*6;
                }
                else if(a[j+1]<a[j]){
                    sum=sum+(a[j]-a[j+1])*4;
                }
            }
            sum=sum+(i-1)*5;
            cout<<sum<<endl;
        }
    }
    return 0;
}