1. 程式人生 > >【PAT】1042. Shuffling Machine (20)

【PAT】1042. Shuffling Machine (20)

題目描述

Shuffling is a procedure used to randomize a deck of playing cards. Because standard shuffling techniques are seen as weak, and in order to avoid “inside jobs” where employees collaborate with gamblers by performing inadequate shuffles, many casinos employ automatic shuffling machines. Your task is to simulate a shuffling machine.

The machine shuffles a deck of 54 cards according to a given random order and repeats for a given number of times. It is assumed that the initial status of a card deck is in the following order:

S1, S2, …, S13, H1, H2, …, H13, C1, C2, …, C13, D1, D2, …, D13, J1, J2

where “S” stands for “Spade”, “H” for “Heart”, “C” for “Club”, “D” for “Diamond”, and “J” for “Joker”. A given order is a permutation of distinct integers in [1, 54]. If the number at the i-th position is j, it means to move the card from position i to position j. For example, suppose we only have 5 cards: S3, H5, C1, D13 and J2. Given a shuffling order {4, 2, 5, 3, 1}, the result will be: J2, H5, D13, S3, C1. If we are to repeat the shuffling again, the result will be: C1, H5, S3, J2, D13.

翻譯:洗牌是一個在牌桌上隨機生成(序列)的過程。因為標準的洗牌技巧看起來很弱,並且為了避免“黑幕”即員工和賭徒合作進行不充分的洗牌,許多賭場僱傭了自動洗牌機。你的任務就是模擬一臺洗牌機。
洗牌機根據一個給定的隨機序列進行洗牌,並且重複給定次數。假設一個牌桌初始的序列為:
S1, S2, …, S13, H1, H2, …, H13, C1, C2, …, C13, D1, D2, …, D13, J1, J2
“S”代表黑桃,“H”代表紅心,“C”代表梅花,“D”代表方塊,“J”代表王。給定的序列是在[1-54]中的唯一數字組成的序列。如果在第i位的數字是j,則代表將卡片從i移到j。舉個例子,假設我們只有5張卡:S3, H5, C1, D13和J2。給定一個洗牌順序 {4, 2, 5, 3, 1}, 洗牌結果將為: J2, H5, D13, S3, C1。如果我們重複該洗牌過程,結果將為:C1, H5, S3, J2, D13。

INPUT FOMRAT

Each input file contains one test case. For each case, the first line contains a positive integer K (<= 20) which is the number of repeat times. Then the next line contains the given order. All the numbers in a line are separated by a space.

翻譯:每個輸入檔案包含一組測試資料。對於每組輸入資料,第一行包括一個正整數K (<= 20)代表重複的次數。接著一行包括給定的順序。所有的數字之間用空格隔開。

OUTPUT FOMRAT

For each test case, print the shuffling results in one line. All the cards are separated by a space, and there must be no extra space at the end of the line.

翻譯:對於每組輸入資料,輸出一行洗牌的結果。所有的卡片之間用空格隔開,並且末尾不能有空格。

Sample Input:

2
36 52 37 38 3 39 40 53 54 41 11 12 13 42 43 44 2 4 23 24 25 26 27 6 7 8 48 49 50 51 9 10 14 15 16 5 17 18 19 1 20 21 22 28 29 30 31 32 33 34 35 45 46 47

Sample Output:

S7 C11 C10 C12 S1 H7 H8 H9 D8 D9 S11 S12 S13 D10 D11 D12 S3 S4 S6 S10 H1 H2 C13 D2 D3 D4 H6 H3 D13 J1 J2 C1 C2 C3 C4 D1 S5 H5 H11 H12 C6 C7 C8 C9 S2 S8 S9 H10 D5 D6 D7 H4 H13 C5

解題思路

定義一個結構體儲存卡片,然後不斷根據給出的順序改變陣列即可。

#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<string>
#include<algorithm>
#define INF 99999999
using namespace std;
struct card{
    char c;int num;
    void print(){
        printf("%c%d",c,num);
    }
};
card s[55];
card temp[55];
int N,Order[55];
void init(){
    for(int i=1;i<=54;i++){
        if(i<=13)s[i].c='S';
        else if(i>13&&i<=26)s[i].c='H';
        else if(i>26&&i<=39)s[i].c='C';
        else if(i>39&&i<=52)s[i].c='D';
        else s[i].c='J';
        s[i].num=i%13==0?13:i%13;
    }   
}
void fun(){
    for(int i=1;i<=54;i++)temp[Order[i]]=s[i];
    for(int i=1;i<=54;i++)s[i]=temp[i];
}
void Print(){
    for(int i=1;i<=54;i++){
        if(i!=1)printf(" ");
        s[i].print();
    }
    printf("\n");   
}
int main(){
    scanf("%d",&N);
    for(int i=1;i<=54;i++)
    scanf("%d",&Order[i]);
    init();
    for(int i=0;i<N;i++)fun();
    Print();
    return 0;
}