1. 程式人生 > >HDU1395 ZOJ1489 2^x mod n = 1【暴力法+數論】

HDU1395 ZOJ1489 2^x mod n = 1【暴力法+數論】

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 17824    Accepted Submission(s): 5582


Problem Description Give a number n, find the minimum x(x>0) that satisfies 2^x mod n = 1.

Input One positive integer on each line, the value of n.

Output If the minimum x exists, print a line with 2^x mod n = 1.

Print 2^? mod n = 1 otherwise.

You should replace x and n with specific numbers.

Sample Input 2 5
Sample Output 2^? mod 2 = 1 2^4 mod 5 = 1
Author MA, Xiao
Source

問題簡述

:對於輸入的n,求滿足 2^x mod n = 1的最小正整數x。

問題分析:若n是偶數或者1則無解,否則用暴力法來解。這個題是一個水題。

程式說明(略)

題記:(略)

參考連結:(略)

AC的C++語言程式如下:

/* HDU1395 ZOJ1489 2^x mod n = 1 */

#include <iostream>
#include <stdio.h>

using namespace std;

int main()
{
    int n;
    while(scanf("%d", &n) != EOF) {
        if(n % 2 == 0 || n == 1)
            printf("2^? mod %d = 1\n", n);
        else {
            int t = 2, x = 1;
            while(t != 1) {
                t *= 2;
                t %= n;
                x++;
            }
            printf("2^%d mod %d = 1\n", x, n);
        }
    }

    return 0;
}