1. 程式人生 > >hdu 1533 Going Home(最小權匹配KM)

hdu 1533 Going Home(最小權匹配KM)

Problem Description On a grid map there are n little men and n houses. In each unit time, every little man can move one unit step, either horizontally, or vertically, to an adjacent point. For each little man, you need to pay a $1 travel fee for every step he moves, until he enters a house. The task is complicated with the restriction that each house can accommodate only one little man.

Your task is to compute the minimum amount of money you need to pay in order to send these n little men into those n different houses. The input is a map of the scenario, a '.' means an empty space, an 'H' represents a house on that point, and am 'm' indicates there is a little man on that point.

You can think of each point on the grid map as a quite large square, so it can hold n little men at the same time; also, it is okay if a little man steps on a grid with a house without entering that house.
Input There are one or more test cases in the input. Each case starts with a line giving two integers N and M, where N is the number of rows of the map, and M is the number of columns. The rest of the input will be N lines describing the map. You may assume both N and M are between 2 and 100, inclusive. There will be the same number of 'H's and 'm's on the map; and there will be at most 100 houses. Input will terminate with 0 0 for N and M.

Output For each test case, output one line with the single integer, which is the minimum amount, in dollars, you need to pay.

Sample Input 2 2 .m H. 5 5 HH..m ..... ..... ..... mm..H 7 8 ...H.... ...H.... ...H.... mmmHmmmm ...H.... ...H.... ...H.... 0 0
Sample Output 2 10 28
Source

題意是給每個人找個房子,人和房子的距離為花費,求最小花費使每個人都有一個房子。。

程式碼:

#include<stdio.h>
#include<string.h>
#include<stdlib.h>
const int maxn=330;
const int inf=1<<31-1;
int n,m;
int w[maxn][maxn];
int lx[maxn],ly[maxn];
int sx[maxn],sy[maxn];
int match[maxn];
int nx,ny;
struct node
{
    int x,y;
}a[maxn],b[maxn];
int find(int u)
{
    sx[u]=1;
    for(int v=1;v<=ny;v++)
    {
        if(!sy[v]&&lx[u]+ly[v]==w[u][v])
        {
            sy[v]=1;
            if(match[v]==-1||find(match[v]))
            {
                match[v]=u;
                return 1;
            }
        }
    }
    return 0;
}
int km(int max_w)
{
    if(!max_w)
    {
        for(int i=1;i<=nx;i++)
            for(int j=1;j<=ny;j++)
            w[i][j]=-w[i][j];
    }
    for(int i=1;i<=nx;i++)
    {
        lx[i]=-inf;
        for(int j=1;j<=ny;j++)
            if(lx[i]<w[i][j])
            lx[i]=w[i][j];
    }
    memset(ly,0,sizeof(ly));
    memset(match,-1,sizeof(match));

    for(int u=1;u<=nx;u++)
    {
        while(1)
        {
            memset(sx,0,sizeof(sx));
            memset(sy,0,sizeof(sy));
            if(find(u))
                break;
            int d=inf;
            for(int i=1;i<=nx;i++)
                if(sx[i])
                for(int j=1;j<=ny;j++)
                if(!sy[j]&&d>lx[i]+ly[j]-w[i][j])
                    d=lx[i]+ly[j]-w[i][j];
            if(d==inf)
                return -1;
            for(int i=1;i<=nx;i++)
            {
                if(sx[i])
                    lx[i]-=d;
            }
            for(int i=1;i<=ny;i++)
            {
                if(sy[i])
                    ly[i]+=d;
            }
        }
    }
    int res=0;
    for(int i=1;i<=ny;i++)
        if(match[i]>=0)
        res+=w[match[i]][i];
    if(!max_w)
        res=-res;
    return res;
}
int main()
{
    //freopen("in.txt","r",stdin);
    while(scanf("%d %d",&n,&m)&&(n+m))
    {
        char s[210];
        nx=0,ny=0;
        for(int i=0;i<n;i++)
        {
            scanf("%s",s);
            for(int j=0;j<m;j++)
            {
                if(s[j]=='m')
                {
                    a[++nx].x=i;
                    a[nx].y=j;
                }
                if(s[j]=='H')
                {
                    b[++ny].x=i;
                    b[ny].y=j;
                }
            }
        }
        //printf("nx=%d ny=%d\n",nx,ny);
        for(int i=1;i<=nx;i++)
            for(int j=1;j<=ny;j++)
              {
                  int cost=abs(a[i].x-b[j].x)+abs(a[i].y-b[j].y);
                  w[i][j]=cost;
              }
//        for(int i=1;i<=nx;i++)
//        {
//            for(int j=1;j<=ny;j++)
//                printf("%d ",w[i][j]);
//            printf("\n");
//        }
        int ans=km(0);
        printf("%d\n",ans);
    }
    return 0;
}