1. 程式人生 > >十六進位制加法 C和C++

十六進位制加法 C和C++

There must be many A + B problems in our HDOJ , now a new one is coming.
Give you two hexadecimal integers , your task is to calculate the sum of them,and print it in hexadecimal too.
Easy ? AC it !
Input The input contains several test cases, please process to the end of the file.
Each case consists of two hexadecimal integers A and B in a line seperated by a blank.
The length of A and B is less than 15.
Output For each test case,print the sum of A and B in hexadecimal in one line.

Sample Input +A -A +1A 12 1A -9 -1A -12 1A -AA
Sample Output 0 2C 11 -2C -90

#include<iostream>

#include<iomanip>
using namespace std;
int main()
{
long long a,b,c;
while(cin>>hex>>a>>b)
{
c=a+b;
if(c>=0)
cout << setiosflags(ios::uppercase)<<hex<<c<<endl;
else
{
c=-c;
cout <<"-"<<setiosflags(ios::uppercase)<<hex <<c<<endl;  
}

}
return 0;
}

利用庫了函式iomanip,

setiosflags(ios::fixed) 固定的浮點顯示 setiosflags(ios::scientific) 指數表示 setiosflags(ios::left) 左對齊 setiosflags(ios::right) 右對齊 setiosflags(ios::skipws) 忽略前導空白 setiosflags(ios::uppercase) 16進位制數大寫輸出 setiosflags(ios::lowercase) 16進位制小寫輸出 setiosflags(ios::showpoint) 強制顯示小數點 setiosflags(ios::showpos) 強制顯示符號 格式化輸出各進位制數: dec 置基數為10 相當於"%d" hex 置基數為16 相當於"%X" oct 置基數為8 相當於"%o"