1. 程式人生 > >HDU 5402 Travelling Salesman Problem

HDU 5402 Travelling Salesman Problem

algorithm else panel ati cin display eight etc maximum

Problem Description Teacher Mai is in a maze with n rows and m columns. There is a non-negative number in each cell. Teacher Mai wants to walk from the top left corner (1,1) to the bottom right corner (n,m). He can choose one direction and walk to this adjacent cell. However, he can‘t go out of the maze, and he can‘t visit a cell more than once.

Teacher Mai wants to maximize the sum of numbers in his path. And you need to print this path.

Input There are multiple test cases.

For each test case, the first line contains two numbers
n,m(1n,m100,n?m2).

In following n lines, each line contains m numbers. The j-th number in the i-th line means the number in the cell (i,j). Every number in the cell is not more than 104.

Output For each test case, in the first line, you should print the maximum sum.

In the next line you should print a string consisting of "L","R","U" and "D", which represents the path you find. If you are in the cell
(x,y), "L" means you walk to cell (x,y?1), "R" means you walk to cell (x,y+1), "U" means you walk to cell (x?1,y), "D" means you walk to cell (x+1,y).

Sample Input
3 3
2 3 3
3 3 3
3 3 2

Sample Output
25
RRDLLDRR
假設n和m裏面有一個是奇數那麽所有走遍就好了。

否則要找一個最小的點不要,這個點的坐標要滿足x+y是奇數假設不是的話,舍棄該點一定會導致另外一個點也走不到。然後找到這個點。暴力的一行一行的跑就好了。

#pragma comment(linker, "/STACK:1024000000,1024000000") 
#include<set>
#include<map>
#include<queue>
#include<stack>
#include<cmath>
#include<cstdio>
#include<vector>
#include<string>
#include<cstring>
#include<algorithm>
#include<functional>
using namespace std;
typedef long long LL;
const LL base = 1e9 + 7;
const int maxn = 105;
LL T, n, m, a[maxn][maxn], sum, x, y;

inline void read(int &x)
{
    char ch;
    while ((ch = getchar())<'0' || ch>'9');
    x = ch - '0';
    while ((ch = getchar()) >= '0' && ch <= '9') x = x * 10 + ch - '0';
}

void get()
{
    x = 1;    y = 2;
    for (int i = 1; i <= n;i++)
        for (int j = 1; j <= m; j++) 
            if (((i + j) & 1) && a[x][y] > a[i][j]) x = i, y = j;
}

int main()
{
    while (scanf("%lld%lld", &n, &m) !=EOF)
    {
        sum = 0;
        for (int i = 1; i <= n;i++)
            for (int j = 1; j <= m; j++)
            {
                scanf("%lld", &a[i][j]);
                sum += a[i][j];
            }
        if (n & 1 || m & 1)
        {
            printf("%lld\n", sum);
            if (n & 1)
            {
                for (int i = 1; i <= n; i++)
                {
                    for (int j = 1; j < m; j++) 
                        if (i & 1) printf("R"); else printf("L");
                    if (i < n) printf("D"); else printf("\n");
                }
            }
            else
            {
                for (int i = 1; i <= m; i++)
                {
                    for (int j = 1; j < n; j++)
                        if (i & 1) printf("D"); else printf("U");
                    if (i < m) printf("R"); else printf("\n");
                }
            }
        }
        else
        {
            get();
            printf("%lld\n", sum - a[x][y]);
            for (int i = 1; i <= n; i += 2)
            {
                if (x == i || x == i + 1)
                {
                    for (int j = 1; j < y; j++)
                    {
                        if (j & 1) printf("D"); else printf("U");
                        printf("R");
                    }
                    if (y < m) printf("R");
                    for (int j = y + 1; j <= m; j++)
                    {
                        if (j & 1) printf("U"); else printf("D");
                        if (j < m) printf("R");
                    }
                    if (i < n - 1) printf("D");
                }
                else if (i < x)
                {
                    for (int j = 1; j < m; j++) printf("R");
                    printf("D");
                    for (int j = 1; j < m; j++) printf("L");
                    printf("D");
                }
                else
                {
                    for (int j = 1; j < m; j++) printf("L");
                    printf("D");
                    for (int j = 1; j < m; j++) printf("R");
                    if (i < n - 1) printf("D");
                }
            }
            printf("\n");
        }
    }
    return 0;
}


HDU 5402 Travelling Salesman Problem