1. 程式人生 > >BestCoder #47 1001&&1002

BestCoder #47 1001&&1002

b+ tco clas min scan main string.h mil height

【比賽鏈接】clikc here~~

ps:真是wuyu~~做了兩小時。A出兩道題,最後由於沒加longlong所有被別人hack掉!,最後竟然不知道hack別人不成功也會掉分。還一個勁的hack 別人的代碼,昨天真是個悲催的比賽,~~~~(>_<)~~~~,以下弱弱獻上代碼~~

1002比1001還簡單~~

1002 Senior‘s Gun

/*
BestCoder Round #47
1002   Senior‘s Gun

*/
#include <iostream>
#include <stdio.h>
#include <string.h>
#include <algorithm>

using namespace std;

#define rep(i,j,k) for(int i=(int)j;i<=(int)k;i++)
#define per(i,j,k) for(int i=(int)j;i>=(int)k;i--)
typedef long long LL;
typedef unsigned long long LLU;
typedef double db;

const int N =2*1e5+10;
int n,m,t,p,res,cnt;
LL ans,tmp;
int num[N];
int aa[N],bb[N];
char str[N];
bool vis[N];

int main()
{
    scanf("%d",&t);
    while (t--)
    {
        scanf("%d%d",&n,&m);
        for (int i=1; i<=n; i++) scanf("%d",&aa[i]);
        for (int i=1; i<=m; i++) scanf("%d",&bb[i]);
        sort(aa+1,aa+n+1);
        sort(bb+1,bb+m+1);
        ans=0;
        int j=n;
        for (int i=1; i<=min(n,m); i++)
            if(aa[j]>bb[i])
            {
                ans+=aa[j]-bb[i];
                j--;
            }
            else break;
        printf("%I64d\n",ans);
    }
    return 0;
}

Sample Input
1
2 2
2 3
2 2
Sample Output
1

1001 Senior‘s Array

/*
BestCoder Round #47
1001   Senior‘s Array

*/
#include <iostream>
#include <stdio.h>
#include <string.h>
#include <algorithm>

using namespace std;

#define rep(i,j,k) for(int i=(int)j;i<=(int)k;i++)
#define per(i,j,k) for(int i=(int)j;i>=(int)k;i--)
typedef long long LL;
typedef unsigned long long LLU;
typedef double db;

const int N =2*1e4+10;
int n,m,t,p;
int aa[N],bb[N];
char str[N];
bool vis[N];

int main()
{
    scanf("%d",&t);
    while (t--)
    {
        scanf("%d%d",&n,&p);
        rep(i,1,n) scanf("%d",&aa[i]);
        LL ans=-1e9;
        rep(i,1,n)
        {
            int tmp=aa[i];
            aa[i]=p;
            LL now=0;
            rep(j,1,n)
            {
                now+=(1ll)*aa[j];
                if(now>ans) ans=now;
                if(now<0) now=0;
            }
            aa[i]=tmp;
        }
        printf("%I64d\n",ans);
    }
    return 0;
}


Sample Input
2
3 5
1 -1 2
3 -2
1 -1 2
Sample Output
8
2

BestCoder #47 1001&amp;&amp;1002