1. 程式人生 > >POJ3321:Apple Tree(樹狀數組)

POJ3321:Apple Tree(樹狀數組)

++ search long long times onos name mon 我們 strong

Description

There is an apple tree outside of kaka‘s house. Every autumn, a lot of apples will grow in the tree. Kaka likes apple very much, so he has been carefully nurturing the big apple tree.

The tree has N forks which are connected by branches. Kaka numbers the forks by 1 to N and the root is always numbered by 1. Apples will grow on the forks and two apple won‘t grow on the same fork. kaka wants to know how many apples are there in a sub-tree, for his study of the produce ability of the apple tree.

The trouble is that a new apple may grow on an empty fork some time and kaka may pick an apple from the tree for his dessert. Can you help kaka?

技術分享

Input

The first line contains an integer N (N ≤ 100,000) , which is the number of the forks in the tree.
The following N - 1 lines each contain two integers u

and v, which means fork u and fork v are connected by a branch.
The next line contains an integer M (M ≤ 100,000).
The following M lines each contain a message which is either
"C x" which means the existence of the apple on fork x has been changed. i.e. if there is an apple on the fork, then Kaka pick it; otherwise a new apple has grown on the empty fork.
or
"Q x
" which means an inquiry for the number of apples in the sub-tree above the fork x, including the apple (if exists) on the fork x
Note the tree is full of apples at the beginning

Output

For every inquiry, output the correspond answer per line.

Sample Input

3
1 2
1 3
3
Q 1
C 2
Q 1

Sample Output

3
2

Source

POJ Monthly--2007.08.05, Huang, Jinsong

題意: 給出一個蘋果樹。每一個節點一開始都有蘋果 C X,假設X點有蘋果。則拿掉。假設沒有。則新長出一個 Q X。查詢X點與它的全部後代分支一共同擁有幾個蘋果
思路: 思路非常巧妙,我們通過自己來編號全部蘋果。每一個節點保存兩個值,左值為本身,右值為其包括的全部後代中最大的編號 我們能夠通過搜索來進行編號,在編好號之後,我們能夠知道。對於某一點而言,我們是先通過這個點搜全然部他的後代編號才結束的,所以這個點的右值。包括了當前點全部的後代與祖先,後代必定是全部編號大於本節點的點,那麽祖先呢,那必定是編號小於這個節點的點了 所以我們通過sum(rig[x])-sum(lef[x]-1)就能得到查詢的答案 至於更新。僅僅須要更新當前點就可以。這樣就轉化為樹狀數組了 一開始我vector使用的vector<int> a[N]。可是一直超時。開始我還沒有發現是這個的問題 後來參考別人的發現沒什麽不同,唯一區別的地方就在這裏,於是嘗試著改動成vector<vector<int> > a(N),結果就A了,坑啊
#include <iostream>
#include <stdio.h>
#include <string.h>
#include <string>
#include <stack>
#include <queue>
#include <map>
#include <set>
#include <vector>
#include <math.h>
#include <bitset>
#include <list>
#include <algorithm>
#include <climits>
using namespace std;

#define lson 2*i
#define rson 2*i+1
#define LS l,mid,lson
#define RS mid+1,r,rson
#define UP(i,x,y) for(i=x;i<=y;i++)
#define DOWN(i,x,y) for(i=x;i>=y;i--)
#define MEM(a,x) memset(a,x,sizeof(a))
#define W(a) while(a)
#define gcd(a,b) __gcd(a,b)
#define LL long long
#define N 100005
#define INF 0x3f3f3f3f
#define EXP 1e-8
#define lowbit(x) (x&-x)
const int mod = 1e9+7;

vector<vector<int> > a(N);
//vector<int> a[N];
int n,m,lef[N],rig[N],c[N],tot,s[N];


int sum(int x)
{
    int ret = 0;
    while(x>0)
    {
        ret+=c[x];
        x-=lowbit(x);
    }
    return ret;
}

void add(int x,int d)
{
    while(x<=n)
    {
        c[x]+=d;
        x+=lowbit(x);
    }
}


void dfs(int x)
{
    lef[x] = tot;
    for(int i = 0; i<a[x].size(); i++)
    {
        tot++;
        dfs(a[x][i]);
    }
    rig[x] = tot;
}
int main()
{
    int i,j,k,x,y;
    char op[5];
    while(~scanf("%d",&n))
    {
        MEM(lef,0);
        MEM(rig,0);
        MEM(s,0);
        MEM(c,0);
        for(i=0; i<N; i++)
            a[i].clear();
        for(i = 1; i<n; i++)
        {
            scanf("%d%d",&x,&y);
            a[x].push_back(y);
        }
        tot = 1;
        dfs(1);
        for(i = 1; i<=n; i++)
        {
            s[i] = 1;
            add(i,1);
        }
        scanf("%d",&m);
        while(m--)
        {
            scanf("%s%d",op,&x);
            if(op[0]==‘Q‘)
            {
                printf("%d\n",sum(rig[x])-sum(lef[x]-1));
            }
            else
            {
                if(s[x])
                    add(lef[x],-1);
                else
                    add(lef[x],1);
                s[x]=!s[x];
            }
        }
    }

    return 0;
}


POJ3321:Apple Tree(樹狀數組)