1. 程式人生 > >【HDU 2669】Romantic

【HDU 2669】Romantic

%d instead col row left tro pac ati pan

Problem Description The Sky is Sprite.
The Birds is Fly in the Sky.
The Wind is Wonderful.
Blew Throw the Trees
Trees are Shaking, Leaves are Falling.
Lovers Walk passing, and so are You.
................................Write in English class by yifenfei
Girls are clever and bright. In HDU every girl like math. Every girl like to solve math problem!
Now tell you two nonnegative integer a and b. Find the nonnegative integer X and integer Y to satisfy X*a + Y*b = 1. If no such answer print "sorry" instead. Input The input contains multiple test cases.
Each case two nonnegative integer a,b (0<a, b<=2^31) Output output nonnegative integer X and integer Y, if there are more answers than the X smaller one will be choosed. If no answer put "sorry" instead. Sample Input 77 51 10 44 34 79 Sample Output 2 -3 sorry 7 -3

題解:

簡單擴展歐幾裏德 判斷gcd是否等於1即可

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
typedef long long ll;
ll exgcd(ll a,ll b,ll &x,ll &y)
{
    if(!b)
    {
        x=1;y=0;
        return a;
    }
    ll r=exgcd(b,a%b,x,y);
    ll t
=x; x=y; y=t-a/b*y; return r; } void work(ll a,ll b) { ll x,y; ll r=exgcd(a,b,x,y); if(r>1) { printf("sorry\n"); return ; } ll t=b/r; x=(x%t+t)%t; y=(r-a*x)/b; printf("%lld %lld\n",x,y); } int main() { int a,b; while(~scanf("%d%d
",&a,&b)) { work(a,b); } return 0; }

【HDU 2669】Romantic