1. 程式人生 > >POJ 2485 Highways 最小生成樹 (Kruskal)

POJ 2485 Highways 最小生成樹 (Kruskal)

between all pac pair content cross cte reel sca

Description

The island nation of Flatopia is perfectly flat. Unfortunately, Flatopia has no public highways. So the traffic is difficult in Flatopia. The Flatopian government is aware of this problem. They‘re planning to build some highways so that it will be possible to drive between any pair of towns without leaving the highway system.

Flatopian towns are numbered from 1 to N. Each highway connects exactly two towns. All highways follow straight lines. All highways can be used in both directions. Highways can freely cross each other, but a driver can only switch between highways at a town that is located at the end of both highways.

The Flatopian government wants to minimize the length of the longest highway to be built. However, they want to guarantee that every town is highway-reachable from every other town.

Input

The first line of input is an integer T, which tells how many test cases followed.
The first line of each case is an integer N (3 <= N <= 500), which is the number of villages. Then come N lines, the i-th of which contains N integers, and the j-th of these N integers is the distance (the distance should be an integer within [1, 65536]) between village i and village j. There is an empty line after each test case.

Output

For each test case, you should output a line contains an integer, which is the length of the longest road to be built such that all the villages are connected, and this value is minimum.

Sample Input

1

3
0 990 692
990 0 179
692 179 0

Sample Output

692

題意: 先輸入T,有T組數據。再輸入有N個點。N行N列 每一個數據代表I點到J點的距離。求完畢一個 最小生成樹種 的  最大邊。

#include<iostream>
#include<cstdio>
#include<algorithm>
using namespace std;
#define q 505
int fa[q];
int map[q][q];
struct node{
	int x,y,l;
}q[q*q/2];
int find(int x)
{
	return x==fa[x]?

x:find(fa[x]); } int cmp(node a,node b) { return a.l<b.l; } int main() { int k,t,n,i,j,max1; scanf("%d",&t); while(t--) { max1=0; k=0; scanf("%d",&n); for(i=1;i<=n;i++) { fa[i]=i; for(j=1;j<=n;j++) { scanf("%d",&map[i][j]); if(i<j) // 優化:去掉重邊還有中間的0 { k++; //不知道有多少邊。這樣統計 q[k].x=i; q[k].y=j; q[k].l=map[i][j]; } } } sort(q+1,q+1+k,cmp); //依據每條邊的距離排序 for(i=1;i<=k;i++) { if(fa[find(q[i].x)]!=fa[find(q[i].y)]) //並查集思想。。

{ fa[find(q[i].x)]=find(q[i].y); if(q[i].l>max1) max1=q[i].l; } } cout<<max1<<endl; } return 0; }


Kruskal 模板。。


POJ 2485 Highways 最小生成樹 (Kruskal)