1. 程式人生 > >hdu 5538 House Building(長春現場賽——水題)

hdu 5538 House Building(長春現場賽——水題)

onos white ng- ron number ots 1.7 mage time

題目鏈接:acm.hdu.edu.cn/showproblem.php?pid=5538

House Building

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 262144/262144 K (Java/Others) Total Submission(s): 621 Accepted Submission(s): 398

Problem Description Have you ever played the video game Minecraft? This game has been one of the world‘s most popular game in recent years. The world of Minecraft is made up of lots of
1×1×1 blocks in a 3D map. Blocks are the basic units of structure in Minecraft, there are many types of blocks. A block can either be a clay, dirt, water, wood, air, ... or even a building material such as brick or concrete in this game.

技術分享

Figure 1: A typical world in Minecraft.


Nyanko-san is one of the diehard fans of the game, what he loves most is to build monumental houses in the world of the game. One day, he found a flat ground in some place. Yes, a super flat ground without any roughness, it‘s really a lovely place to build houses on it. Nyanko-san decided to build on a
n×m big flat ground, so he drew a blueprint of his house, and found some building materials to build.

While everything seems goes smoothly, something wrong happened. Nyanko-san found out he had forgotten to prepare glass elements, which is a important element to decorate his house. Now Nyanko-san gives you his blueprint of house and asking for your help. Your job is quite easy, collecting a sufficient number of the glass unit for building his house. But first, you have to calculate how many units of glass should be collected.

There are
n rows and m columns on the ground, an intersection of a row and a column is a 1×1 square,and a square is a valid place for players to put blocks on. And to simplify this problem, Nynako-san‘s blueprint can be represented as an integer array ci,j(1in,1jm). Which ci,j indicates the height of his house on the square of i-th row and j-th column. The number of glass unit that you need to collect is equal to the surface area of Nyanko-san‘s house(exclude the face adjacent to the ground).
Input The first line contains an integer T indicating the total number of test cases.
First line of each test case is a line with two integers n,m.
The n lines that follow describe the array of Nyanko-san‘s blueprint, the i-th of these lines has m integers ci,1,ci,2,...,ci,m, separated by a single space.

1T50
1n,m50
0ci,j1000
Output For each test case, please output the number of glass units you need to collect to meet Nyanko-san‘s requirement in one line.
Sample Input
2
3 3
1 0 0
3 1 2
1 1 0
3 3
1 0 1
0 0 0
1 0 1

Sample Output
30
20

技術分享
Figure 2: A top view and side view image for sample test case 1.

Source

field=problem&key=2015ACM%2FICPC%D1%C7%D6%DE%C7%F8%B3%A4%B4%BA%D5%BE-%D6%D8%CF%D6%C8%FC%A3%A8%B8%D0%D0%BB%B6%AB%B1%B1%CA%A6%B4%F3%A3%A9&source=1&searchmode=source" style="color:rgb(26,92,200); text-decoration:none">2015ACM/ICPC亞洲區長春站-重現賽(感謝東北師大)
Recommend hujie | We have carefully selected several similar problems for you: 5664 5663 5662 5661 5660
題目大意: 題目大意:給你積木圖的鳥瞰圖。(i,j)位置放了一個高度為a[i][j]的積木,求表面積(不算下表面)。


解題思路:簽到題吧,從上下左右四個方向掃一下相鄰兩個積木的高度差就能夠了。 詳見代碼。

#include <iostream>
#include <cstdio>
#include <cstring>

using namespace std;

int main()
{
    int t,n,m,k,ans;
    int a[110][110];
    scanf("%d",&t);
    while (t--)
    {
        memset(a,0,sizeof(a));
        scanf("%d%d",&n,&m);
        k=0;
        for (int i=1;i<=n;i++)
        {
            for (int j=1;j<=m;j++)
            {
                scanf("%d",&a[i][j]);
                if (a[i][j]>0)
                    k++;
            }
        }
        for (int i=1;i<=n;i++)
        {
            for (int j=1;j<=m;j++)
            {
                ans=a[i][j]-a[i][j+1];
                if (ans>0)
                    k+=ans;
            }
        }
        for (int i=1;i<=n;i++)
        {
            for (int j=1;j<=m;j++)
            {
                ans=a[i][j]-a[i][j-1];
                if (ans>0)
                    k+=ans;
            }
        }
        for (int i=1;i<=n;i++)
        {
            for (int j=1;j<=m;j++)
            {
                ans=a[i][j]-a[i-1][j];
                if (ans>0)
                    k+=ans;
            }
        }
        for (int i=1;i<=n;i++)
        {
            for (int j=1;j<=m;j++)
            {
                ans=a[i][j]-a[i+1][j];
                if (ans>0)
                    k+=ans;
            }
        }
        printf ("%d\n",k);
    }
    return 0;
}



hdu 5538 House Building(長春現場賽——水題)