1. 程式人生 > >HDU 5573 Binary Tree (構造)

HDU 5573 Binary Tree (構造)

mat tom 方式 title span cat 但是 them special

Binary Tree

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 1353 Accepted Submission(s): 796
Special Judge


Problem Description The Old Frog King lives on the root of an infinite tree. According to the law, each node should connect to exactly two nodes on the next level, forming a full binary tree.

Since the king is professional in math, he sets a number to each node. Specifically, the root of the tree, where the King lives, is 1
. Say froot=1 .

And for each node
u , labels as fu , the left child is fu×2 and right child is fu×2+1 . The king looks at his tree kingdom, and feels satisfied.

Time flies, and the frog king gets sick. According to the old dark magic, there is a way for the king to live for another
N years, only if he could collect exactly
N soul gems.

Initially the king has zero soul gems, and he is now at the root. He will walk down, choosing left or right child to continue. Each time at node
x , the number at the node is fx (remember froot=1 ), he can choose to increase his number of soul gem by fx , or decrease it by fx .

He will walk from the root, visit exactly
K nodes (including the root), and do the increasement or decreasement as told. If at last the number is N , then he will succeed.

Noting as the soul gem is some kind of magic, the number of soul gems the king has could be negative.

Given
N , K , help the King find a way to collect exactly N soul gems by visiting exactly K nodes.

Input First line contains an integer T , which indicates the number of test cases.

Every test case contains two integers
N and K , which indicates soul gems the frog king want to collect and number of nodes he can visit.

? 1T100 .

? 1N109 .

? N2K260 .

Output For every test case, you should output "Case #x:" first, where x indicates the case number and counts from 1 .

Then
K lines follows, each line is formated as ‘a b‘, where a is node label of the node the frog visited, and b is either ‘+‘ or ‘-‘ which means he increases / decreases his number by a .

It‘s guaranteed that there are at least one solution and if there are more than one solutions, you can output any of them.

Sample Input 2 5 3 10 4

Sample Output Case #1: 1 + 3 - 7 + Case #2: 1 + 3 + 6 - 12 + 一開始基於本題的性質,也能想到跟二進制有關,但是沒想到具體的運用方法.- - 當時註意到該題的範圍說明很特別,但沒特別在意,這是很不應該的. 正確的思考路線,我想可以先打個表,就會發現,這些數據很多的合理組成方式都跟1 2 4 8等等密切相關, 然後將思路往二進制上面轉化,把1個數轉化為2進制之後,就會是1+2+4等類似的形式,比如101就是1+4, 但是這裏的二進制是不僅不加,還要減去對應的位數,也就是說對於2的k次方-1來說,就會減去兩倍的位數. 那麽我們將2的k次方-1和n的差,除以2,再按2進制進行題目要求的操作,是不是就能得到n了呢。 如果差為奇數,我們將差先加一再除以2,這樣會多減1,所以最後一個數走右邊即可。 上面討論的是n<2的k次方的情況,最後特殊一下n==2的k次方的情況 代碼如下:
#include <cstdio>
#include <iostream>
#include <algorithm>
#include <cstring>
using namespace std;
typedef long long ll;
ll a[110];
int main()
{
   ll t,n,k,Case=0,cha,tmp,cnt,h;
   scanf("%lld",&t);
   while(t--)
   {
       Case++;
     scanf("%lld%lld",&n,&k);
        cha=(1<<(k))-1-n;
     memset(a,0,sizeof(a));
       if(cha%2==1)
       tmp=(cha+1)/2;
       else
       tmp=cha/2;
       cnt=0;
       while(tmp>0)
       {
          a[cnt++]=tmp%2;
          tmp=tmp/2;
       }
       printf("Case #%lld:\n",Case);
       for(ll i=0;i<k-1;i++)
       {
           h=(1<<i);
         if(a[i]==0)
         {
          printf("%lld +\n",h);
         }
         else
         printf("%lld -\n",h);
       }
      if(cha%2==1||n==(1<<(k)))
       printf("%lld +\n",(1<<k-1)+1);
     else
        printf("%lld +\n",(1<<k-1));

   }
    return 0;
}

HDU 5573 Binary Tree (構造)