1. 程式人生 > >PAT1090:Highest Price in Supply Chain

PAT1090:Highest Price in Supply Chain

find problem tro efi expec case 零售商 build imu

1090. Highest Price in Supply Chain (25)

時間限制 200 ms 內存限制 65536 kB 代碼長度限制 16000 B 判題程序 Standard 作者 CHEN, Yue

A supply chain is a network of retailers(零售商), distributors(經銷商), and suppliers(供應商)-- everyone involved in moving a product from supplier to customer.

Starting from one root supplier, everyone on the chain buys products from one‘s supplier in a price P and sell or distribute them in a price that is r% higher than P. It is assumed that each member in the supply chain has exactly one supplier except the root supplier, and there is no supply cycle.

Now given a supply chain, you are supposed to tell the highest price we can expect from some retailers.

Input Specification:

Each input file contains one test case. For each case, The first line contains three positive numbers: N (<=105), the total number of the members in the supply chain (and hence they are numbered from 0 to N-1); P, the price given by the root supplier; and r, the percentage rate of price increment for each distributor or retailer. Then the next line contains N numbers, each number Si

is the index of the supplier for the i-th member. Sroot for the root supplier is defined to be -1. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the highest price we can expect from some retailers, accurate up to 2 decimal places, and the number of retailers that sell at the highest price. There must be one space between the two numbers. It is guaranteed that the price will not exceed 1010

.

Sample Input:
9 1.80 1.00
1 5 4 4 -1 4 5 3 6
Sample Output:
1.85 2

思路
這道題歸根結底就是用dfs求圖(或者說樹)的根節點到終點(或者說樹的葉節點)最大路徑maxLength,那麽利潤的增長次數就是maxLength - 1,此時價格最大。那麽步驟可以是:

1.根據輸入構造圖
2.dfs找最大路徑maxlength,並統計最大路徑的次數。
3.最大價格 = price * pow( 1 + rate , maxLength - 1)
4.輸出最大價格(兩位小數)和最大路徑的出現次數。

代碼
#include<iostream>
#include<vector>
#include<iomanip>
using namespace std;

vector<int> levels(100002,0);


//dfs and count level‘s num
void dfs(const vector<vector<int>>& graph,int root,int level)
{
   levels[level]++;
   if(graph[root].empty())
      return;
   for(int i = 0;i < graph[root].size();i++)
     dfs(graph,graph[root][i],level + 1);
}


int main()
{
  int N;
  double price,rate;
  while(cin >> N >> price >> rate)
  {
      vector<vector<int>> graph(N);
      int root = 0;
      //build graph
      for(int i = 0;i < N;i++)
      {
          int father;
          cin >> father;
          if(father == - 1)
            root = i;
          else
            graph[father].push_back(i);
      }
      
      //dfs
      dfs(graph,root,1);
      
      //find the maximum depth
      int maxLength = 0;
      for(int i = 1; i <levels.size();i++)
      {
          if(levels[i] == 0)
          {
              maxLength = i - 1 ;
              break;
          }
      }
      //calculate price
      for(int i = 0;i < maxLength - 1;i++)
      {
          price *= (1 + rate/100);
      }
      cout << fixed << setprecision(2) << price << " ";
      cout << levels[maxLength] << endl;
      levels.clear();
  }
}

PAT1090:Highest Price in Supply Chain