1. 程式人生 > >HDU 2006 求奇數的乘積

HDU 2006 求奇數的乘積

otto bottom space highlight true while CP 輸出 problem

http://acm.hdu.edu.cn/showproblem.php?pid=2006

Problem Description 給你n個整數,求他們中所有奇數的乘積。 Input 輸入數據包含多個測試實例,每個測試實例占一行,每行的第一個數為n,表示本組數據一共有n個,接著是n個整數,你可以假設每組數據必定至少存在一個奇數。 Output 輸出每組數中的所有奇數的乘積,對於測試實例,輸出一行。 Sample Input 3 1 2 3 4 2 3 4 5 Sample Output 3 15 代碼:
#include <bits/stdc++.h>

using namespace std;


int main()
{
    int n;
    while(cin>>n)
    {
        int sum=1;
        for(int i=1; i<=n; i++)
        {
            int x;
            cin>>x;
            if(x%2!=0)
                sum*=x;
        }
        cout<<sum<<endl;
    }
    return 0;
}

  

HDU 2006 求奇數的乘積