1. 程式人生 > >杭電多校第三場 A Ascending Rating

杭電多校第三場 A Ascending Rating

it is xor esc pri main param ack led preview

Problem Description Before the start of contest, there are n ICPC contestants waiting in a long queue. They are labeled by 1 to n from left to right. It can be easily found that the i-th contestant‘s QodeForces rating is ai.
Little Q, the coach of Quailty Normal University, is bored to just watch them waiting in the queue. He starts to compare the rating of the contestants. He will pick a continous interval with length m
, say [l,l+m?1], and then inspect each contestant from left to right. Initially, he will write down two numbers maxrating=?1and count=0. Everytime he meets a contestant k with strictly higher rating than maxrating, he will change maxrating to ak and count to count+1.
Little T is also a coach waiting for the contest. He knows Little Q is not good at counting, so he is wondering what are the correct final value of maxrating
and count. Please write a program to figure out the answer.

Input The first line of the input contains an integer T(1T2000), denoting the number of test cases.
In each test case, there are 7 integers n,m,k,p,q,r,MOD(1m,kn107,5p,q,r,MOD109) in the first line, denoting the number of contestants, the length of interval, and the parameters k,p,q,r,MOD
.
In the next line, there are k integers a1,a2,...,ak(0ai109), denoting the rating of the first k contestants.
To reduce the large input, we will use the following generator. The numbers p,q,r and MOD are given initially. The values ai(k<in) are then produced as follows :
ai=(p×ai?1+q×i+r)modMOD
It is guaranteed that n7×107 and k2×106.

Output Since the output file may be very large, let‘s denote maxratingi and counti as the result of interval [i,i+m?1].
For each test case, you need to print a single line containing two integers A and B, where :
AB==i=1n?m+1(maxratingii)i=1n?m+1(countii)
Note that ``‘‘ denotes binary XOR operation.

Sample Input 1 10 6 10 5 5 5 5 3 2 2 1 5 7 6 8 2 9 Sample Output 46 11 題意:輸入 n,m,k,p,q,r,MOD 輸入k個數,總共有n個數,如果輸入不夠的話就由上面那個公式把剩下的補齊,然後區間長度為m,訪問所有的長度m的區間, 我們要求每個區間的最大值變化次數 (比如 3 2 2 1 5 7 那麽我們的最大值3-5-7 所以次數是3,最大值是7) 和最大值 ,然後求每個區間的變化次數和最大值分別異或第幾個區間號i的累加和 思路:一看復雜度,只有o(n)可以過,那麽就去想o(n)算法,乍一看最大值就是用一個滑動窗口可以求出來是o(n)的,但是count我們不好記錄,我們可以發現count的那些最大值 其實是一個單調遞增的序列,我們想怎麽去維護呢,我們求最大值那麽肯定就要用o(n)了,我們可不可以同時求呢,說明我的單調序列也要能盡量沿用上一個區間的值,避免遍歷 我們可以回想下,求滑動窗口的時候那個隊列就是存的一個以隊列首為最大值的一個最長單調遞減序列,那麽我們怎麽由遞減序列變成遞增序列呢,很簡單,我們倒著求滑動窗口 到時候隊列長度即是最大值的變化次數
#include<cstdio>
#include<cstring>
#include<cmath>
#include<iostream>
#include<deque>
#include<vector>
#include<algorithm>
using namespace std;
int n,m,t,k,p,q,r,mod;
int a[1000001];
int b[1000001];
int c[1000001];
deque<int> qx,qn;
int cnt;
int main()
{
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d%d%d%d%d%d%d",&n,&m,&k,&p,&q,&r,&mod);
        for(int i=0;i<k;i++)
            scanf("%d",&a[i]);
        for(int i=k;i<n;i++)
            a[i]=(p*a[i-1]+q*i+r)%mod;
        int x=0,y=0;
        for(int i=n-1;i>=0;i--)
        {
            while(!qx.empty()&&a[i]>=a[qx.back()])
                 qx.pop_back();
            qx.push_back(i);
            if(i<=n-m)
            {
                while(!qx.empty()&&qx.front()>=i+m) qx.pop_front();
                x+=(i+1)^a[qx.front()];
                y+=(i+1)^qx.size();
            }
        }    
        printf("%d %d\n",x,y);
    }
    
}

杭電多校第三場 A Ascending Rating