1. 程式人生 > >HDU1224 Free DIY Tour(SPFA)

HDU1224 Free DIY Tour(SPFA)

ask esp using const ins and add format 數組

Free DIY Tour

Problem Description

Weiwei is a software engineer of ShiningSoft. He has just excellently fulfilled a software project with his fellow workers. His boss is so satisfied with their job that he decide to provide them a free tour around the world. It‘s a good chance to relax themselves. To most of them, it‘s the first time to go abroad so they decide to make a collective tour.
The tour company shows them a new kind of tour circuit - DIY circuit. Each circuit contains some cities which can be selected by tourists themselves. According to the company‘s statistic, each city has its own interesting point. For instance, Paris has its interesting point of 90, New York has its interesting point of 70, ect. Not any two cities in the world have straight flight so the tour company provide a map to tell its tourists whether they can got a straight flight between any two cities on the map. In order to fly back, the company has made it impossible to make a circle-flight on the half way, using the cities on the map. That is, they marked each city on the map with one number, a city with higher number has no straight flight to a city with lower number.
Note: Weiwei always starts from Hangzhou(in this problem, we assume Hangzhou is always the first city and also the last city, so we mark Hangzhou both 1

and N+1), and its interesting point is always 0.
Now as the leader of the team, Weiwei wants to make a tour as interesting as possible. If you were Weiwei, how did you DIY it?

Input

The input will contain several cases. The first line is an integer T which suggests the number of cases. Then T cases follows.
Each case will begin with an integer N(2 ≤ N ≤ 100) which is the number of cities on the map.
Then N integers follows, representing the interesting point list of the cities.
And then it is an integer M followed by M pairs of integers [Ai, Bi] (1 ≤ i ≤ M). Each pair of [Ai, Bi] indicates that a straight flight is available from City Ai to City Bi.

Output

For each case, your task is to output the maximal summation of interesting points Weiwei and his fellow workers can get through optimal DIYing and the optimal circuit. The format is as the sample. You may assume that there is only one optimal circuit.
Output a blank line between two cases.

Sample Input

2
3
0 70 90
4
1 2
1 3
2 4
3 4
3
0 90 70
4
1 2
1 3
2 4
3 4

Sample Output

CASE 1#
points : 90
circuit : 1->3->1

CASE 2#
points : 90
circuit : 1->2->1

題解

題意

每個城市有訪問點數,只能按照訪問點數遞增的順序訪問城市,求最多能達到的訪問點數是多少?

思路

模板,利用SPFA算法,將訪問點數設置為訪問代價。求得代價最大的最長路。

註意路徑的保存方法,SPFA可以利用前驅數組的方式保存,每次更新時修改前驅數組的值即可。

代碼

#pragma comment(linker, "/STACK:1024000000,1024000000")
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<iostream>
#include<string>
#include<vector>
#include<stack>
#include<bitset>
#include<cstdlib>
#include<cmath>
#include<set>
#include<list>
#include<deque>
#include<map>
#include<queue>
using namespace std;
typedef long long ll;
const double PI = acos(-1.0);
const double eps = 1e-6;
const int INF = 0x3f3f3f3f;

#define REP(i,n) for(int i=0;i<(n);i++)


int N;

struct Edge{
    int from;
    int to;
    int val;
    Edge(int u,int v,int w):from(u),to(v),val(w){}
};

const int MAXN = 1e5+10;
vector<Edge>edges;
vector<int>G[MAXN];
int dis[MAXN];
int vis[MAXN];
int cnt[MAXN];
int point[MAXN];
int pre[MAXN];

void init(){
    memset(dis,-INF,sizeof(dis));
    memset(vis,0,sizeof(vis));
    memset(cnt,0,sizeof(cnt));
    memset(pre,-1,sizeof(pre));
    memset(point,0,sizeof(point));
    for(int i=0;i<MAXN;i++) G[i].clear();
    edges.clear();
}
void addedge(int u,int v,int w){
    edges.push_back(Edge(u,v,w));
    G[u].push_back(edges.size()-1);
}

bool SPFA(int s){
    queue<int> q1;
    q1.push(s);
    vis[s] = 1;
    dis[s] = 0;
    while(q1.empty()==0){
        int u = q1.front();
        q1.pop();
        vis[u] = 0;
        for(int i=0;i<G[u].size();i++){
            Edge cur = edges[G[u][i]];
            if(dis[cur.to]<dis[u]+cur.val){
                dis[cur.to]=dis[u]+cur.val;
                pre[cur.to] = u;
                if(!vis[cur.to]){
                    vis[cur.to]= 1;
                    q1.push(cur.to);
                    if(++cnt[cur.to]>N) return false;
                }
            }
        }
    }
    
}

void path(int u){
    if(pre[u]==-1){
        printf("1");
        return;
    }
    path(pre[u]);
    if(u==N) printf("->%d",1);
    else printf("->%d",u);
}

int main(){
    int T = 0;
    scanf("%d",&T);
    int kase = 0;
    while(T--){
        init();
        kase++;
        scanf("%d",&N);
        for(int i=1;i<=N;i++){
            scanf("%d",&point[i]);
        }
        N++;
        int M = 0;
        scanf("%d",&M);
        for(int i=0;i<M;i++){
            int u,v;
            scanf("%d %d",&u,&v);
            addedge(u,v,point[v]);
        }
        SPFA(1);
        if(kase!=1)printf("\n");
        printf("CASE %d#\n", kase);
        printf("points : %d\n", dis[N]);
        printf("circuit : ");
        path(N);
        printf("\n");
    }
    return 0;
}

HDU1224 Free DIY Tour(SPFA)