1. 程式人生 > >hdu 3038 How Many Answers Are Wrong (帶權並查集)

hdu 3038 How Many Answers Are Wrong (帶權並查集)

with 等於 重要 個數 father rom int for 區間

How Many Answers Are Wrong

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 14876 Accepted Submission(s): 5237


Problem Description TT and FF are ... friends. Uh... very very good friends -________-b

FF is a bad boy, he is always wooing TT to play the following game with him. This is a very humdrum game. To begin with, TT should write down a sequence of integers-_-!!(bored).
技術分享圖片

Then, FF can choose a continuous subsequence from it(for example the subsequence from the third to the fifth integer inclusively). After that, FF will ask TT what the sum of the subsequence he chose is. The next, TT will answer FF‘s question. Then, FF can redo this process. In the end, FF must work out the entire sequence of integers.

Boring~~Boring~~a very very boring game!!! TT doesn‘t want to play with FF at all. To punish FF, she often tells FF the wrong answers on purpose.

The bad boy is not a fool man. FF detects some answers are incompatible. Of course, these contradictions make it difficult to calculate the sequence.

However, TT is a nice and lovely girl. She doesn‘t have the heart to be hard on FF. To save time, she guarantees that the answers are all right if there is no logical mistakes indeed.

What‘s more, if FF finds an answer to be wrong, he will ignore it when judging next answers.

But there will be so many questions that poor FF can‘t make sure whether the current answer is right or wrong in a moment. So he decides to write a program to help him with this matter. The program will receive a series of questions from FF together with the answers FF has received from TT. The aim of this program is to find how many answers are wrong. Only by ignoring the wrong answers can FF work out the entire sequence of integers. Poor FF has no time to do this job. And now he is asking for your help~(Why asking trouble for himself~~Bad boy)

Input Line 1: Two integers, N and M (1 <= N <= 200000, 1 <= M <= 40000). Means TT wrote N integers and FF asked her M questions.

Line 2..M+1: Line i+1 contains three integer: Ai, Bi and Si. Means TT answered FF that the sum from Ai to Bi is Si. It‘s guaranteed that 0 < Ai <= Bi <= N.

You can assume that any sum of subsequence is fit in 32-bit integer.

Output A single line with a integer denotes how many answers are wrong.

Sample Input 10 5 1 10 100 7 10 28 1 3 32 4 6 41 6 6 1

Sample Output 1

Source 2009 Multi-University Training Contest 13 - Host by HIT 題目路徑: http://acm.hdu.edu.cn/showproblem.php?pid=3038 題意大概就是:一個數列,按順序給你若幹個區間的和,若某個區間的和與之前的沖突,就忽略,問你一共有多少個沖突的和。 帶權並查集的一道例題。 帶權並查集,其實就是說一個集合中的元素互相之間可以確定一種關系。初學時接觸的並查集,其實就是說一個集合中的元素是一種“等價”關系,是帶權並查集的一個特例。一個集合中的元素互相之間有關系,這便是(帶權)並查集的本質。這點很重要,有必要理解下。 至於這道題,每個元素其實存放0...i的和(i的範圍是1...n)以及與其父親節點和的差值。find和union操作與簡單並查集略有不同,主要是要更新兩個值了。代碼中只寫了find(finding)操作,union操作在main函數中實現的。這題還有一個點,[a,b]的和就等於[0,b]-[0,a-1]的和(是a-1,而不是a)。 一些實現的細節還是要靠自己寫,體會體會了。 還有一道更經典的例題,poj上的《食物鏈》。大家可以看一看,如果不會寫的話(其實和這題差不多^_^),網上題解還是很多的。 技術分享圖片
#include <cstdio>

using namespace std;

const int maxn=200000;

struct
{
    int fa;
    int rel;//保存和其父親節點前綴和的差值
}father[maxn+10];

int finding(int x)
{
    if(father[x].fa==x)
        return x;
    int tmp=father[x].fa;
    father[x].fa=finding(tmp);
    father[x].rel=father[x].rel+father[tmp].rel;//更新關系
    return father[x].fa;
}

int main()
{
    int n,m;
    while(scanf("%d%d",&n,&m)!=EOF)
    {
        for(int i=0;i<=n;i++)//0..n而不是1..n(盡管點的編號是1..n)
        {
            father[i].fa=i;
            father[i].rel=0;
        }
        int ans=0;
        while(m--)
        {
            int a,b,s;
            scanf("%d%d%d",&a,&b,&s);
            a--;//這點文中已經有解釋了

            int aroot=finding(a);
            int broot=finding(b);
            if(aroot==broot)
            {
                if(father[b].rel-father[a].rel!=-s)
                ans++;
            }
            else
            {
                father[aroot].fa=broot;
                father[aroot].rel=-father[a].rel+father[b].rel+s;
            }
            //printf("%d\n",ans);
        }
        printf("%d\n",ans);
    }
    return 0;
}
View Code

hdu 3038 How Many Answers Are Wrong (帶權並查集)