1. 程式人生 > >HDU - 5512 Pagodas

HDU - 5512 Pagodas

from NPU stand open thml text 題意 stream turn

n pagodas were standing erect in Hong Jue Si between the Niushou Mountain and the Yuntai Mountain, labelled from 1 to n. However, only two of them (labelled a and b, where 1abn) withstood the test of time.

Two monks, Yuwgna and Iaka, decide to make glories great again. They take turns to build pagodas and Yuwgna takes first. For each turn, one can rebuild a new pagodas labelled

i (i?{a,b} and 1in) if there exist two pagodas standing erect, labelled j and k respectively, such that i=j+k or i=j?k

. Each pagoda can not be rebuilt twice.

This is a game for them. The monk who can not rebuild a new pagoda will lose the game. InputThe first line contains an integer t (1t500)
which is the number of test cases.
For each test case, the first line provides the positive integer n (2n20000) and two different integers a and b.OutputFor each test case, output the winner (``Yuwgna" or ``Iaka"). Both of them will make the best possible decision each time.Sample Input
16
2 1 2
3 1 3
67 1 2
100 1 2
8 6 8
9 6 8
10 6 8
11 6 8
12 6 8
13 6 8
14 6 8
15 6 8
16 6 8
1314 6 8
1994 1 13
1994 7 12
Sample Output
Case #1: Iaka
Case #2: Yuwgna
Case #3: Yuwgna
Case #4: Iaka
Case #5: Iaka
Case #6: Iaka
Case #7: Yuwgna
Case #8: Yuwgna
Case #9: Iaka
Case #10: Iaka
Case #11: Yuwgna
Case #12: Yuwgna
Case #13: Iaka
Case #14: Yuwgna
Case #15: Iaka
Case #16: Iaka
思路: 即使是數學水題,對我來說都是一項巨大的挑戰,數學這麽差,真的是玩不下去啦。 看了一下題解,才勉強弄懂了寫法。 首先,這個題意讓我琢磨不清,按照我的做法,應該是Iaka先走才對。 假設有n為正無窮,a=15,b=10,那麽這兩位老和尚可以建造的塔就是5,10,15,20,25,30。。。。 不難發現全部都是gcd(a,b)的倍數,所以當n不是正無窮時,可以建造的塔的數量也就只有n/gcd(a,b)種了。 而且,這n/gcd(a,b)個數一定會全部出現,所以把會出現的數字的個數再判斷一下奇偶就行啦。 代碼
#include<iostream>
#include<algorithm>
#include<vector>
#include<queue>
#include<deque>
#include<stack>
#include<map>
#include<set>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<cstdlib>
#define fuck(x) cout<<#x<<" = "<<x<<endl;
using namespace std;
typedef long long ll;
typedef unsigned long long ull;
const int maxn = 100086;
const int inf = 2.1e9;
const ll INF = 999999999999999;
const double eps = 1e-6;

int gcd(int a,int b)
{
    return b?gcd(b,a%b):a;
}

int main()
{
//    ios::sync_with_stdio(false);
//    freopen("in.txt","r",stdin);

    int T;
    scanf("%d",&T);
    int n,a,b;
    int cases = 0;
    while(T--){
        cases++;
        scanf("%d%d%d",&n,&a,&b);
        int ans  =n/gcd(a,b);
        fuck(ans)
        printf("Case #%d: ",cases);
        if(ans&1){printf("Yuwgna\n");}
        else printf("Iaka\n");
    }


    return 0;
}

HDU - 5512 Pagodas