1. 程式人生 > >HDU 2896 病毒入侵 AC自動機

HDU 2896 病毒入侵 AC自動機

病毒侵襲

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 37537    Accepted Submission(s): 8304


 

Problem Description

當太陽的光輝逐漸被月亮遮蔽,世界失去了光明,大地迎來最黑暗的時刻。。。。在這樣的時刻,人們卻異常興奮——我們能在有生之年看到500年一遇的世界奇觀,那是多麼幸福的事兒啊~~
但網路上總有那麼些網站,開始藉著民眾的好奇心,打著介紹日食的旗號,大肆傳播病毒。小t不幸成為受害者之一。小t如此生氣,他決定要把世界上所有帶病毒的網站都找出來。當然,誰都知道這是不可能的。小t卻執意要完成這不能的任務,他說:“子子孫孫無窮匱也!”(愚公後繼有人了)。
萬事開頭難,小t收集了好多病毒的特徵碼,又收集了一批詭異網站的原始碼,他想知道這些網站中哪些是有病毒的,又是帶了怎樣的病毒呢?順便還想知道他到底收集了多少帶病毒的網站。這時候他卻不知道何從下手了。所以想請大家幫幫忙。小t又是個急性子哦,所以解決問題越快越好哦~~

 

 

Input

第一行,一個整數N(1<=N<=500),表示病毒特徵碼的個數。
接下來N行,每行表示一個病毒特徵碼,特徵碼字串長度在20—200之間。
每個病毒都有一個編號,依此為1—N。
不同編號的病毒特徵碼不會相同。
在這之後一行,有一個整數M(1<=M<=1000),表示網站數。
接下來M行,每行表示一個網站原始碼,原始碼字串長度在7000—10000之間。
每個網站都有一個編號,依此為1—M。
以上字串中字元都是ASCII碼可見字元(不包括回車)。

 

 

Output

依次按如下格式輸出按網站編號從小到大輸出,帶病毒的網站編號和包含病毒編號,每行一個含毒網站資訊。
web 網站編號: 病毒編號 病毒編號 …
冒號後有一個空格,病毒編號按從小到大排列,兩個病毒編號之間用一個空格隔開,如果一個網站包含病毒,病毒數不會超過3個。
最後一行輸出統計資訊,如下格式
total: 帶病毒網站數
冒號後有一個空格。

 

 

Sample Input

 

3 aaa bbb ccc 2 aaabbbccc bbaacc

 

 

Sample Output

 

web 1: 1 2 3 total: 1

 

#include<stdio.h>
#include<string.h>
#include<queue>
#include<algorithm>
using namespace std;
const int maxm = 100005;
const int mod = 10007;
int tr[maxm][130], fail[maxm], last[maxm], cnt;
int ans[maxm], tot, vis[maxm];
char str[maxm];
void insert(int id)
{
	int len = strlen(str);
	int now = 0;
	for (int i = 0;i < len;i++)
	{
		int num = str[i];
		if (!tr[now][num])
			tr[now][num] = ++cnt;
		now = tr[now][num];
	}
	last[now] = id;
}
void find_fail()
{
	int now;
	queue<int>q;
	for (int i = 0;i <= 128;i++)
		if (tr[0][i]) q.push(tr[0][i]);
	while (!q.empty())
	{
		now = q.front();q.pop();
		for (int i = 0;i <= 128;i++)
		{
			if (tr[now][i])
			{
				fail[tr[now][i]] = tr[fail[now]][i];
				q.push(tr[now][i]);
			}
			else tr[now][i] = tr[fail[now]][i];
		}
	}
}
void query()
{
	int now = 0;
	int len = strlen(str);
	memset(vis, 0, sizeof(vis));
	for (int i = 0;i < len;i++)
	{
		vis[now] = 1;
		int num = str[i];
		int v = tr[now][num];
		while (v && !vis[v])
		{
			vis[v] = 1;
			if (last[v])
				ans[++tot] = last[v];
			v = fail[v];
		}
		now = tr[now][num];
	}
}
int main()
{
	int n, i, j, k, m, now, t, sum;
	scanf("%d", &n);
	for (i = 1;i <= n;i++)
	{
		scanf("%s", str);
		insert(i);
	}
	find_fail();
	scanf("%d", &m);
	sum = 0;
	for (i = 1;i <= m;i++)
	{
		scanf("%s", str);
		tot = 0;
		query();
		if (tot)
		{
			printf("web %d: ", i);
			sort(ans + 1, ans + 1 + tot);
			for (j = 1;j <= tot;j++)
				printf("%d%c", ans[j], j == tot ? '\n' : ' ');
			sum++;
		}
	}
	printf("total: %d\n", sum);
	return 0;
}