1. 程式人生 > >【矩陣快速冪】HDU - 5950 C - Recursive sequence

【矩陣快速冪】HDU - 5950 C - Recursive sequence

C - Recursive sequence HDU - 5950

Farmer John likes to play mathematics games with his N cows. Recently, they are attracted by recursive sequences. In each turn, the cows would stand in a line, while John writes two positive numbers a and b on a blackboard. And then, the cows would say their identity number one by one. The first cow says the first number a and the second says the second number b. After that, the i-th cow says the sum of twice the (i-2)-th number, the (i-1)-th number, and i4

. Now, you need to write a program to calculate the number of the N-th cow in order to check if John’s cows can make it right.

Input

The first line of input contains an integer t, the number of test cases. t test cases follow.
Each case contains only one line with three numbers N, a and b where N,a,b < 231

as described above.

Output

For each test case, output the number of the N-th cow. This number might be very large, so you need to output it modulo 2147493647.

Sample Input

2
3 1 2
4 1 10

Sample Output

85
369     

Hint

In the first case, the third number is 85 = 2*1十2十3^4.
 In the second case, the third number is 93 = 2*1十1*10十3^4 and the fourth number is 369 = 2 * 10 十 93 十 4^4.
        
 構造7維矩陣,進行矩陣快速冪 A[i]=2*A[i-2]+A[i-1]+i^4   A[i+1]=2*A[i-1]+A[i]+(i+1)^4

(i+1)^4=i^4+4*i^3+6*i^2+4*i+1   (i+1)^3=i^3+3*i^2+3*i+1  (i+1)^2=i^2+2*i+1  (i+1)^1=i+1 (i+1)^0=1

特別注意:矩陣A*矩陣B 不等於 矩陣B*矩陣A

#include <bits/stdc++.h>
#define ll long long
using namespace std;
const ll mod=2147493647;
ll n,a1,b1;
struct node
{
    ll a[7][7];
};

node matrix(node x,node y)
{
    node r;
    memset(r.a,0,sizeof(r.a));
    for(int i=0;i<7;i++)
    {
        for(int j=0;j<7;j++)
        {
            for(int k=0;k<7;k++)
            {
                r.a[i][j]+=x.a[i][k]*y.a[k][j];
                r.a[i][j]%=mod;
            }
        }
    }
    return r;
}

ll quickpow(ll n,node r)
{
    node c;
    memset(c.a,0,sizeof(c.a));
    c.a[0][0]=1,c.a[0][1]=2,c.a[0][2]=1,c.a[0][3]=4,c.a[0][4]=6,c.a[0][5]=4,c.a[0][6]=1;
    c.a[1][0]=1;
    c.a[2][2]=1,c.a[2][3]=4,c.a[2][4]=6,c.a[2][5]=4,c.a[2][6]=1;
    c.a[3][3]=1,c.a[3][4]=3,c.a[3][5]=3,c.a[3][6]=1;
    c.a[4][4]=1,c.a[4][5]=2,c.a[4][6]=1;
    c.a[5][5]=1,c.a[5][6]=1;
    c.a[6][6]=1;
    while(n)
    {
        if(n%2) r=matrix(c,r);
        c=matrix(c,c);
        n/=2;
    }
    return r.a[0][0];
}

int main()
{
    int T;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%lld%lld%lld",&n,&a1,&b1);
        node r;
        memset(r.a,0,sizeof(r.a));
        r.a[0][0]=b1%mod,r.a[1][0]=a1%mod,r.a[2][0]=16,r.a[3][0]=8,r.a[4][0]=4,r.a[5][0]=2,r.a[6][0]=1;
        if(n==1) printf("%lld\n",a1%mod);
        else if(n==2) printf("%lld\n",b1%mod);
        else printf("%lld\n",quickpow(n-2,r));
    }
    return 0;
}