1. 程式人生 > >【POJ】1862:Stripies【貪心】【優先佇列】

【POJ】1862:Stripies【貪心】【優先佇列】

Stripies
Time Limit: 1000MS   Memory Limit: 30000K
Total Submissions: 20456   Accepted: 9098

Description

Our chemical biologists have invented a new very useful form of life called stripies (in fact, they were first called in Russian - polosatiki, but the scientists had to invent an English name to apply for an international patent). The stripies are transparent amorphous amebiform creatures that live in flat colonies in a jelly-like nutrient medium. Most of the time the stripies are moving. When two of them collide a new stripie appears instead of them. Long observations made by our scientists enabled them to establish that the weight of the new stripie isn't equal to the sum of weights of two disappeared stripies that collided; nevertheless, they soon learned that when two stripies of weights m1 and m2 collide the weight of resulting stripie equals to 2*sqrt(m1*m2). Our chemical biologists are very anxious to know to what limits can decrease the total weight of a given colony of stripies. 

You are to write a program that will help them to answer this question. You may assume that 3 or more stipies never collide together. 

Input

The first line of the input contains one integer N (1 <= N <= 100) - the number of stripies in a colony. Each of next N lines contains one integer ranging from 1 to 10000 - the weight of the corresponding stripie.

Output

The output must contain one line with the minimal possible total weight of colony with the accuracy of three decimal digits after the point.

Sample Input

3
72
30
50

Sample Output

120.000

Source

Northeastern Europe 2001, Northern Subregion

Solution

題目是求按$2*\sqrt{m1*m2}$兩兩合併能得到的最小值

假設有$a,b,c $且結果是$r$ 則 $r = 2*\sqrt{2*\sqrt{a*b}*c}$ 則$\frac{r^2}{8}=\sqrt{a*b*c*c}$若要 $r$ $c$定是$a,b,c$中最小的 所以就是不斷地取兩個大數相乘

每次貪心取最大的兩個元素合併即可....用優先佇列實現吧....

(話說為什麼poj上面必須選C++才過得了啊!!!還找了白天錯QAQ

Code

#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<algorithm>
#include<queue>
#define DB double
using namespace std;

int n;
DB a;
priority_queue < DB > q;

int main() {
    scanf("%d", &n);
    for(int i = 1; i <= n; i ++)    scanf("%lf", &a), q.push(a);
    while(q.size() > 1) {
        DB x = q.top(); q.pop();
        DB y = q.top(); q.pop();
        DB now = 2 * sqrt(x * y);
        q.push(now);
    }
    printf("%0.3lf\n", q.top());
    return 0;
}