1. 程式人生 > >【HDU - 2398 】Savings Account (水題模擬)

【HDU - 2398 】Savings Account (水題模擬)

題幹:

Suppose you open a savings account with a certain initial balance. You will not make any withdrawals or further deposits for a number of years. The bank will compound your balance (add the annual interest) once a year, on the anniversary of the opening of the account. Your goal is to achieve a certain target amount in your savings account. In how may years will the target amount be achieved?

Input

The input file will contain data for one or more test cases, one test case per line. Each line will contain three numbers: the initial balance, the annual interest rate (as a percentage of the balance), and the target amount, separated by blank spaces. These will be positive numbers; they may or may not contain a decimal point. The target amount will be greater than the initial balance. The input is terminated by end-of-file

Output

For each line of input, your program will produce exactly one line of output: This line will contain one positive integer value: the number of years required to achieve the target amount.

Sample Input

200.00 6.5 300
500 4 1000.00

Sample Output

7
18

題目大意:

    給本金和銀行利率和最後取款  求多少年後可達到。。。

解題報告:

   簽到的大水題,不解釋了。

AC程式碼:

#include<bits/stdc++.h>
using namespace std;
double down,rate,up;
int main() 
{
	while(cin>>down>>rate>>up) {
		int ans = 0;
		rate /= 100;
		while(down < up) {
			down = (1+rate) * down;
			ans++;
		}
		cout << ans << endl;		
	}

	return 0 ;
}