1. 程式人生 > >Java練習 SDUT-3339_計算長方形的周長和麵積(類和物件)

Java練習 SDUT-3339_計算長方形的周長和麵積(類和物件)

計算長方形的周長和麵積(類和物件)

Time Limit: 1000 ms Memory Limit: 65536 KiB

Problem Description

設計一個長方形類Rect,計算長方形的周長與面積。
成員變數:整型、私有的資料成員length(長)、width(寬);
構造方法如下:
(1)Rect(int length) —— 1個整數表示正方形的邊長
(2)Rect(int length, int width)——2個整數分別表示長方形長和寬
成員方法:包含求面積和周長。(可適當新增其他方法)
要求:編寫主函式,對Rect類進行測試,輸出每個長方形的長、寬、周長和麵積。

Input

輸入多組資料;
一行中若有1個整數,表示正方形的邊長;
一行中若有2個整數(中間用空格間隔),表示長方形的長度、寬度。
若輸入資料中有負數,則不表示任何圖形,長、寬均為0。

Output

每行測試資料對應一行輸出,格式為:(資料之間有1個空格)
長度 寬度 周長 面積

Sample Input

1
2 3
4 5
2
-2
-2 -3

Sample Output

1 1 4 1
2 3 10 6
4 5 18 20
2 2 8 4
0 0 0 0
0 0 0 0

習慣性的認為長比寬長,所以在賦值的時候WA了一發。

import java.util.Scanner;

public class Main {

    public static void main(String[] args) {
        Scanner cin = new Scanner(System.in);
        String str;
        String []s;
        Rect a;
        while(cin.hasNext())
        {
            str = cin.nextLine();
            s = str.split(" ");
            if(s.length==1)
                a = new Rect(Integer.parseInt(s[0]));
            else
                a = new Rect(Integer.parseInt(s[0]),Integer.parseInt(s[1]));
        }
        cin.close();
    }

}

class Rect
{
    private int l,w;
    Rect(int l,int w)
    {
        this.l = l;
        this.w = w;
        if(l<=0||w<=0)
        {
            this.l = this.w = 0;
        }
        System.out.println(this.l+" "+this.w+" "+(this.l+this.w)*2+" "+this.l*this.w);
    }
    Rect(int l)
    {
        if(l<=0)
            this.l = this.w = 0;
        else
            this.l = this.w = l;
        System.out.println(this.l+" "+this.w+" "+(this.l+this.w)*2+" "+this.l*this.w);
    }
}