1. 程式人生 > >Java之計算長方形的周長和麵積(類和物件)

Java之計算長方形的周長和麵積(類和物件)

Problem Description

設計一個長方形類Rect,計算長方形的周長與面積。

成員變數:整型、私有的資料成員length(長)、width(寬);

構造方法如下:

(1)Rect(int length) —— 1個整數表示正方形的邊長

(2)Rect(int length, int width)——2個整數分別表示長方形長和寬

成員方法:包含求面積和周長。(可適當新增其他方法)

要求:編寫主函式,對Rect類進行測試,輸出每個長方形的長、寬、周長和麵積。

Input

 輸入多組資料;

一行中若有1個整數,表示正方形的邊長;

一行中若有2個整數(中間用空格間隔),表示長方形的長度、寬度。

若輸入資料中有負數,則不表示任何圖形,長、寬均為0。

Output

 每行測試資料對應一行輸出,格式為:(資料之間有1個空格)

長度 寬度 周長 面積

Sample Input

1
2 3
4 5
2
-2
-2 -3

Sample Output

1 1 4 1
2 3 10 6
4 5 18 20
2 2 8 4
0 0 0 0
0 0 0 0

tip:用輸入字串的形式輸入以及通過切割函式來判斷如數的個數;

import java.util.*;
 
class Rect{
	public int n;
	public int m;
	Rect(int n){
		System.out.println(n+" "+n+" "+4*n+" "+n*n);
	}
	Rect(int n, int m){
		System.out.println(n+" "+m+" "+(2*n+2*m)+" "+m*n);
	}
}
 
public class Main{
	public static void main(String args[]){
		Scanner scanner = new Scanner(System.in);
		while ( scanner.hasNext() ){
			String h = scanner.nextLine();
			char[] a = h.toCharArray();
			int temp = 0;
			int i;
			for ( i = 0;i < a.length; i++ ){
				if ( a[i] == ' ' )
					temp = 1;
			}
			if ( temp == 0 ){
				int b = Integer.parseInt(h);
				if ( b <= 0 )
					System.out.println("0 0 0 0");
				else{
				    Rect h1 = new Rect(b);}
			}
			else {
				String[] h3 = h.split(" ");
				int e = Integer.parseInt(h3[0]);
				int r = Integer.parseInt(h3[1]);
				if ( e <= 0||r <= 0 )
					System.out.println("0 0 0 0");
				else{
				    Rect h1 = new Rect(e,r);}
			}
		}
	}
}