1. 程式人生 > >"巴卡斯杯" 中國大學生程式設計競賽 - 女生專場 C - Luck Competition

"巴卡斯杯" 中國大學生程式設計競賽 - 女生專場 C - Luck Competition

Participants of the Luck Competition choose a non-negative integer no more than 100 in their mind. After choosing their number, let KK be the average of all numbers, and MM be the result of K×23K×23. Then the lucky person is the one who choose the highest number no more than MM. If there are several such people, the lucky person is chosen randomly. 

If you are given a chance to know how many people are participating the competition and what their numbers are, calculate the highest number with the highest probability to win assuming that you're joining the competition. 

Input

There are several test cases and the first line contains the number of test cases T(T≤10)T(T≤10). 

Each test case begins with an integer N(1<N≤100)N(1<N≤100), denoting the number of participants. And next line contains N−1N−1 numbers representing the numbers chosen by other participants. 
 

Output

For each test case, output an integer which you have chosen and the probability of winning (round to two digits after the decimal point), seperated by space. 
 

Sample Input

3
4
1 2 3
4
1 1 2
4
20 30 40

Sample Output

1 0.50
0 1.00
18 1.00
#include<iostream>
using namespace std;
int a[1000]; 
int main()
{
	int n,m,j,k,i,T;
	cin>>T;
	while (T--)
	{
		int sum=0;
		scanf("%d",&n);
		for (i=0;i<n-1;i++)
		{
			cin>>a[i];
			sum+=a[i];
		}
			
		int SUM=1;
		int ans = (double)2.0*sum/(3.0*n-2.0);
		for (i=0;i<n-1;i++)
		{
			if (a[i]==ans)
			SUM++;
		}
		double ANS = 1.0/double(SUM);
		printf("%d %.2lf\n",ans,ANS);
	}
	
	return 0;
 }