1. 程式人生 > >PAT 1135 Is It A Red-Black Tree[難]

PAT 1135 Is It A Red-Black Tree[難]

case spa scanf tor ear cor mat pre %d

1135 Is It A Red-Black Tree (30 分)

There is a kind of balanced binary search tree named red-black tree in the data structure. It has the following 5 properties:

  • (1) Every node is either red or black.
  • (2) The root is black.
  • (3) Every leaf (NULL) is black.
  • (4) If a node is red, then both its children are black.
  • (5) For each node, all simple paths from the node to descendant leaves contain the same number of black nodes.

For example, the tree in Figure 1 is a red-black tree, while the ones in Figure 2 and 3 are not.

技術分享圖片技術分享圖片技術分享圖片
Figure 1 Figure 2 Figure 3

For each given binary search tree, you are supposed to tell if it is a legal red-black tree.

Input Specification:

Each input file contains several test cases. The first line gives a positive integer K (≤30) which is the total number of cases. For each case, the first line gives a positive integer N (≤30), the total number of nodes in the binary tree. The second line gives the preorder traversal sequence of the tree. While all the keys in a tree are positive integers, we use negative signs to represent red nodes. All the numbers in a line are separated by a space. The sample input cases correspond to the trees shown in Figure 1, 2 and 3.

Output Specification:

For each test case, print in a line "Yes" if the given tree is a red-black tree, or "No" if not.

Sample Input:

3
9
7 -2 1 5 -4 -11 8 14 -15
9
11 -2 1 -7 5 -4 8 14 -15
8
10 -7 5 -6 8 15 -11 17

Sample Output:

Yes
No
No

題目大意:給出了紅黑樹的定義,並且給出n組樣例,並且每一組給除了先根遍歷結果,判斷每一組是否是紅黑樹,紅色節點用負號表示。

//可以用先根遍歷來確定一棵二叉樹嗎?

1.根節點是黑色

2.如果一個節點是黑色,那麽子節點為紅色

3.在所有從根節點到葉節點的路徑上,黑色節點的個數相同。

紅黑樹也是一個二叉搜索樹,所以能夠根據前序來建樹!!  

代碼轉自:https://www.liuchuo.net/archives/4099

#include <iostream>
#include <vector>
#include <cmath>
#include<cstdio>
using namespace std;
vector<int> arr;
struct node {
    int val;
    struct node *left, *right;
};
node* build(node *root, int v) {
    if(root == NULL) {
        root = new node();
        root->val = v;
        root->left = root->right = NULL;
    } else if(abs(v) <= abs(root->val))
        root->left = build(root->left, v);//遞歸建樹!!!
    else
        root->right = build(root->right, v);
    return root;
}
bool judge1(node *root) {
    if (root == NULL) return true;
    if (root->val < 0) {
        //如果當前是紅色節點,去判斷左右子樹是否是黑色節點。
        if (root->left != NULL && root->left->val < 0) return false;
        if (root->right != NULL && root->right->val < 0) return false;
    }
    //再遞歸地去判斷左子節點的子數,和右子節點的子數。
    return judge1(root->left) && judge1(root->right);
}
int getNum(node *root) {
    if (root == NULL) return 0;//這裏是返回個數0.
    int l = getNum(root->left);
    int r = getNum(root->right);
    return root->val > 0 ? max(l, r) + 1 : max(l, r);
    //如果根節點是黑節點,那麽+1.
}
bool judge2(node *root) {
    if (root == NULL) return true;
    int l = getNum(root->left);//獲取左右子樹的黑節點個數。
    int r = getNum(root->right);
    if(l != r) return false;//圖三在根節點調用時在此處就會返回false。
    return judge2(root->left) && judge2(root->right);//再去遞歸判斷子樹中是否符合,
    //像圖二就會在這次遞歸中判斷為false.
}
int main() {
    int k, n;
    scanf("%d", &k);
    for (int i = 0; i < k; i++) {
        scanf("%d", &n);
        arr.resize(n);
        node *root = NULL;
        for (int j = 0; j < n; j++) {
            scanf("%d", &arr[j]);
            root = build(root, arr[j]);
        }
        //如果根節點不是紅色,
        if (arr[0] < 0 || judge1(root) == false || judge2(root) == false)
            printf("No\n");
        else
            printf("Yes\n");
    }
    return 0;
}

//柳神真厲害。

1.二叉樹這類問題都是使用遞歸去做的,掌握遞歸的思想十分重要。

2.根據條件去寫出函數來判斷。

3.要多復習。

PAT 1135 Is It A Red-Black Tree[難]