1. 程式人生 > >【編程訓練-PAT】A1135 Is It A Red-Black Tree (30 分)

【編程訓練-PAT】A1135 Is It A Red-Black Tree (30 分)

watermark per inpu sea rate ifdef mark pre avl

1135 Is It A Red-Black Tree (30 分)
There is a kind of balanced binary search tree named red-black tree in the data structure. It has the following 5 properties:

(1) Every node is either red or black.

(2) The root is black.

(3) Every leaf (NULL) is black.

(4) If a node is red, then both its children are black.

(5) For each node, all simple paths from the node to descendant leaves contain the same number of black nodes.
For example, the tree in Figure 1 is a red-black tree, while the ones in Figure 2 and 3 are not.
技術分享圖片
For each given binary search tree, you are supposed to tell if it is a legal red-black tree.


Input Specification:
Each input file contains several test cases. The first line gives a positive integer K (≤30) which is the total number of cases. For each case, the first line gives a positive integer N (≤30), the total number of nodes in the binary tree. The second line gives the preorder traversal sequence of the tree. While all the keys in a tree are positive integers, we use negative signs to represent red nodes. All the numbers in a line are separated by a space. The sample input cases correspond to the trees shown in Figure 1, 2 and 3.
Output Specification:
For each test case, print in a line "Yes" if the given tree is a red-black tree, or "No" if not.

Sample Input:
3
9
7 -2 1 5 -4 -11 8 14 -15
9
11 -2 1 -7 5 -4 8 14 -15
8
10 -7 5 -6 8 15 -11 17

Sample Output:
Yes
No
No

分析:紅黑樹需要滿足三個條件:
1. 根節點是黑色的

  1. 紅色節點的孩子節點是黑色的
  2. 任何節點左右子樹的黑色節點個數相等(由路徑中的黑色節點個數相等推出)
    條件1直接判斷,條件2和3遞歸實現,具體的思路來自於AVL樹的求高度等一系列操作
#include<iostream>
#include<cstdio>
#include<vector>
#include<unordered_map>
#include<string>
#include<set>
#include<algorithm>
#include<cmath>
using namespace std;
const int nmax = 50;
int pre[nmax] = {0};
struct node{
    int data;
    node *lchild, *rchild;
};
typedef node* pnode;
pnode creat(int pL, int pR){
    if(pL > pR)return NULL;
    pnode root = new node;
    root-> data = pre[pL];
    root->lchild = root->rchild = NULL;
    int pos = pL + 1;
    while(pos <= pR && abs(pre[pos]) < abs(pre[pL]))pos++;
    root->lchild = creat(pL + 1, pos - 1);
    root->rchild = creat(pos, pR);
    return root;
}
bool judge1(pnode root){
    if(root == NULL)return true;
    if(root->data < 0){
        if(root->lchild != NULL && root->lchild->data < 0)return false;
        if(root->rchild != NULL && root->rchild->data < 0)return false;
    }
    return judge1(root->lchild) && judge1(root->rchild);
}
int getH(pnode root){
    if(root == NULL)return 0;
    int l = getH(root->lchild), r = getH(root->rchild);
    return root->data > 0 ? max(l, r) + 1 : max(l, r);
}
bool judge2(pnode root){
    if(root == NULL)return true;
    int l = getH(root->lchild), r = getH(root->rchild);
    if(l != r)return false;
    return judge2(root->lchild) && judge2(root->rchild);
}
int main(){
    #ifdef ONLINE_JUDGE
    #else
    freopen("input.txt", "r", stdin);
    #endif
    int n;
    scanf("%d", &n);
    for(int i = 0; i < n; ++i){
        int m;
        scanf("%d", &m);
        for(int j = 0; j < m; ++j)scanf("%d", &pre[j]);
        pnode root = creat(0, m - 1);
        if(root->data < 0 || judge1(root) == false || judge2(root) == false)printf("No\n");
        else printf("Yes\n");
    }
    return 0;
}

【編程訓練-PAT】A1135 Is It A Red-Black Tree (30 分)