1. 程式人生 > >【編程訓練-PAT】A1119 Pre- and Post-order Traversals (30 分)

【編程訓練-PAT】A1119 Pre- and Post-order Traversals (30 分)

lse vector txt cif sap push_back you any nodes

1119 Pre- and Post-order Traversals (30 分)

Suppose that all the keys in a binary tree are distinct positive integers. A unique binary tree can be determined by a given pair of postorder and inorder traversal sequences, or preorder and inorder traversal sequences. However, if only the postorder and preorder traversal sequences are given, the corresponding tree may no longer be unique.

Now given a pair of postorder and preorder traversal sequences, you are supposed to output the corresponding inorder traversal sequence of the tree. If the tree is not unique, simply output any one of them.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤ 30), the total number of nodes in the binary tree. The second line gives the preorder sequence and the third line gives the postorder sequence. All the numbers in a line are separated by a space.

Output Specification:

For each test case, first printf in a line Yes if the tree is unique, or No if not. Then print in the next line the inorder traversal sequence of the corresponding binary tree. If the solution is not unique, any answer would do. It is guaranteed that at least one solution exists. All the numbers in a line must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input 1:

7
1 2 3 4 6 7 5
2 6 7 4 5 3 1

Sample Output 1:

Yes
2 1 6 4 7 3 5

Sample Input 2:

4
1 2 3 4
2 4 3 1

Sample Output 2:

No
2 1 3 4

分析:根據序列建樹,關鍵還是左右子樹的劃分,先序序列為N L R,後序為L R N,可以首先確定下根節點,後序中的R又可以分為L R N,因此後序的倒數第二個就是右子樹的根節點,在先序序列中尋找該節點的位置就能確定左右子樹,當\(pos = preL + 1\)時,就會出現不唯一的情況

#include<iostream>
#include<cstdio>
#include<vector>
#include<unordered_map>
#include<string>
#include<set>
#include<algorithm>
#include<cmath>
using namespace std;
const int nmax = 40;
int pre[nmax], post[nmax];
struct node{
    int v;
    node *lchild, *rchild;
};
typedef node* pnode;
bool uq = true;
pnode creat(int preL, int preR, int postL, int postR){
    if(preL > preR)return NULL;
    if(preL == preR){
        pnode root = new node;
        root->v = pre[preL];
        root->lchild = root->rchild = NULL;
        return root;
    }//這是為了防止在尋找pos時發生數組越界
    pnode root = new node;
    root->v = pre[preL];
    root->lchild = root->rchild = NULL;
    int pos = preL + 1;
    while(pre[pos] != post[postR - 1])pos++;
    if(pos == preL + 1)uq = false;
    int numleft = pos - preL - 1;
    root->lchild = creat(preL + 1, pos - 1, postL, postL + numleft - 1);
    root->rchild = creat(pos, preR, postL + numleft, postR - 1);
    return root;
}
vector<int>ans;
void inOrder(pnode root){
    if(root == NULL)return;
    inOrder(root->lchild);
    ans.push_back(root->v);
    inOrder(root->rchild);
}
int main(){
    #ifdef ONLINE_JUDGE
    #else
    freopen("input.txt", "r", stdin);
    #endif
    int n;
    scanf("%d", &n);
    for(int i = 0; i < n; ++i)scanf("%d", &pre[i]);
    for(int i = 0; i < n; ++i)scanf("%d", &post[i]);
    pnode root = creat(0, n - 1, 0, n - 1);
    if(uq == true)printf("Yes\n");
    else printf("No\n");
    inOrder(root);
    for(int i = 0; i < ans.size(); ++i){
        if(i > 0)cout<<" ";
        cout<<ans[i];
    }
    cout<<endl;//要輸出這個換行符,否則會顯示格式錯誤
    return 0;
}

【編程訓練-PAT】A1119 Pre- and Post-order Traversals (30 分)