1. 程式人生 > >hdu2069Coin Change解題報告---DFS深搜

hdu2069Coin Change解題報告---DFS深搜

Coin Change

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 23934    Accepted Submission(s): 8373


 

Problem Description

Suppose there are 5 types of coins: 50-cent, 25-cent, 10-cent, 5-cent, and 1-cent. We want to make changes with these coins for a given amount of money.

For example, if we have 11 cents, then we can make changes with one 10-cent coin and one 1-cent coin, or two 5-cent coins and one 1-cent coin, or one 5-cent coin and six 1-cent coins, or eleven 1-cent coins. So there are four ways of making changes for 11 cents with the above coins. Note that we count that there is one way of making change for zero cent.

Write a program to find the total number of different ways of making changes for any amount of money in cents. Your program should be able to handle up to 100 coins.

Input

The input file contains any number of lines, each one consisting of a number ( ≤250 ) for the amount of money in cents.

Output

For each input line, output a line containing the number of different ways of making changes with the above 5 types of coins.

Sample Input

11

26

Sample Output

4

13

 題意:

用1,5,10,25,50五種面值的硬幣組成面值為n的硬幣

坑點在於英文題...硬幣總數<=100沒看清,WA了一下

資料不大,深搜就行

看很多大佬都是dp和母函式過的,待會去學習一波

#include<iostream>
#include<sstream>
#include<cstdlib>
#include<cmath>
#include<cctype>
#include<algorithm>
#include<cstring>
#include<cstdio>
#include<map>
#include<vector>
#include<stack>
#include<queue>
#include<set>
#include<list>
#define mod 998244353
#define INF 0x3f3f3f3f
#define Min 0xc0c0c0c0
#define mst(a) memset(a,0,sizeof(a))
#define f(i,a,b) for(int i=a;i<b;i++)
using namespace std;
typedef long long ll;
const int maxn = 1e6 + 5;
const double pi = acos(-1);
const int v[5] = {1, 5, 10, 25, 50};
int n;
int res;
void dfs(int sum, int ans, int s, int num){ 
    //sum表示當前組成的面值,ans代表n值,s代表搜尋深度(0,4),num代表硬幣數
    if(num > 100) return ;
    if(sum == ans){
        res++;
        return;
    }
    if(sum > ans) return;
    for(int i = s; i < 5; i++){
        if(sum + v[i] > ans) return;
        dfs(v[i] + sum, ans, i, num + 1);
    }
}
int main(){
    while(scanf("%d", &n) != EOF){
        if(n == 0){
            printf("1\n");
            continue;
        }
        res = 0;
        for(int i = 0; i < 5; i++){
            dfs(v[i], n, i, 1);
        }
        printf("%d\n", res);
    }
    return 0;
}