1. 程式人生 > >HDU1051 Wooden Sticks(貪心&結構體排序)

HDU1051 Wooden Sticks(貪心&結構體排序)

There is a pile of n wooden sticks. The length and weight of each stick are known in advance. The sticks are to be processed by a woodworking machine in one by one fashion. It needs some time, called setup time, for the machine to prepare processing a stick. The setup times are associated with cleaning operations and changing tools and shapes in the machine. The setup times of the woodworking machine are given as follows: 

(a) The setup time for the first wooden stick is 1 minute. 
(b) Right after processing a stick of length l and weight w , the machine will need no setup time for a stick of length l' and weight w' if l<=l' and w<=w'. Otherwise, it will need 1 minute for setup. 

You are to find the minimum setup time to process a given pile of n wooden sticks. For example, if you have five sticks whose pairs of length and weight are (4,9), (5,2), (2,1), (3,5), and (1,4), then the minimum setup time should be 2 minutes since there is a sequence of pairs (1,4), (3,5), (4,9), (2,1), (5,2). 

Input

The input consists of T test cases. The number of test cases (T) is given in the first line of the input file. Each test case consists of two lines: The first line has an integer n , 1<=n<=5000, that represents the number of wooden sticks in the test case, and the second line contains n 2 positive integers l1, w1, l2, w2, ..., ln, wn, each of magnitude at most 10000 , where li and wi are the length and weight of the i th wooden stick, respectively. The 2n integers are delimited by one or more spaces. 

Output

The output should contain the minimum setup time in minutes, one per line. 

Sample Input

3 
5 
4 9 5 2 2 1 3 5 1 4 
3 
2 2 1 1 2 2 
3 
1 3 2 2 3 1

Sample Output

2
1
3

 

題意:給出n條木棍進行加工,對於setup time有如下定義:初始加工第一根木棍的setup time為1,如果前一個l1,w1和後一根l2,w2滿足l2>=l1&&w2>=w1則加工後一根的setup time為0(不需要重置機器),如果不滿足則需要重置機器即setup time+1,求加工完這n條木棍的最少setup time.

解題思路:

貪心。要求最少的加工時間可以對木棍進行排序分成幾個序列,使得每個序列裡的l和w的差值儘可能小,這樣每個序列只需要1單位的setup time,最後只需統計下有多少序列則需要多少setup time。

但是我們無法同時對兩個主元進行排序,所以先對一個主元進行排序,然後對另一個主元貪心。

貪心的過程就是找到各個序列的過程,先對第一個沒有被標記的木棍進行貪心,找到下一個滿足條件的就標記找過了……

注意判斷的過程中每個木棍是與上一個木棍作比較,所以不要忘記更新比較的物件x。

 

AC程式碼:

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;

struct stick
{
	int length,weight;
} a[5010];

bool cmp(stick a,stick b)
{
//	if(a.weight==b.weight) return a.length<b.length;
//	return a.weight<b.weight;
	if(a.length==b.length) return a.weight<b.weight;
	return a.length<b.length;
}

int book[5010];

int main()
{
	int t,n;
	scanf("%d",&t);
	while(t--)
	{
		memset(a,0,sizeof(a));
		memset(book,0,sizeof(book));
		scanf("%d",&n);
		for(int i=0;i<n;i++)
		{
			scanf("%d%d",&a[i].length,&a[i].weight);
		}
		sort(a,a+n,cmp);
//		for(int i=0;i<n;i++)
//		{
//			printf("%d %d\n",a[i].length,a[i].weight);
//		}
		
		int sum=0;
		for(int i=0;i<n;i++)
		{
			if(book[i]==0)
			{
				book[i]=1;
				int x=a[i].weight;
				for(int j=i+1;j<n;j++)
				{
					if((a[j].weight>=x)&&book[j]==0)
					{
						x=a[j].weight;
						book[j]=1;
					}
				}
				sum++;
			}
		}
		printf("%d\n",sum);
	}
	return 0;
}