1. 程式人生 > >HDU-Wooden Sticks(貪心)

HDU-Wooden Sticks(貪心)

Wooden Sticks

There is a pile of n wooden sticks. The length and weight of each stick are known in advance. The sticks are to be processed by a woodworking machine in one by one fashion. It needs some time, called setup time, for the machine to prepare processing a stick. The setup times are associated with cleaning operations and changing tools and shapes in the machine. The setup times of the woodworking machine are given as follows:

(a) The setup time for the first wooden stick is 1 minute.
(b) Right after processing a stick of length l and weight w , the machine will need no setup time for a stick of length l' and weight w' if l<=l' and w<=w'. Otherwise, it will need 1 minute for setup.

You are to find the minimum setup time to process a given pile of n wooden sticks. For example, if you have five sticks whose pairs of length and weight are (4,9), (5,2), (2,1), (3,5), and (1,4), then the minimum setup time should be 2 minutes since there is a sequence of pairs (1,4), (3,5), (4,9), (2,1), (5,2).

Input

The input consists of T test cases. The number of test cases (T) is given in the first line of the input file. Each test case consists of two lines: The first line has an integer n , 1<=n<=5000, that represents the number of wooden sticks in the test case, and the second line contains n 2 positive integers l1, w1, l2, w2, ..., ln, wn, each of magnitude at most 10000 , where li and wi are the length and weight of the i th wooden stick, respectively. The 2n integers are delimited by one or more spaces.

Output

The output should contain the minimum setup time in minutes, one per line.

Sample Input

3 
5 
4 9 5 2 2 1 3 5 1 4 
3 
2 2 1 1 2 2 
3 
1 3 2 2 3 1

Sample Output

2
1
3

題目連結:

http://acm.hdu.edu.cn/showproblem.php?pid=1051

 題意描述:

給你n組區間,存在包含關係的區間為相同區間,問共有多少組不同的區間。

解題思路:

先把這些區間存到結構體中,然後對區間的首端進行從小到大排序,然後再在這n個區間中從前往後遍歷,只要這個區間未被遍歷過,並且該區間的尾端大於與之比較的區間的尾端(記得更新區間,每比較一次區間,該區間就要被更新,也就是程式中的q),那麼就證明這兩個區間屬於相同區間。

程式程式碼:

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
struct data{
	int a;
	int b;
}s[5010];
int book[5010];

int cmp(data x,data y);

int main()
{
	int T,n,i,j,sum,q;
	scanf("%d",&T);
	while(T--)
	{
		scanf("%d",&n);
		sum=n;
		for(i=0;i<n;i++)
			scanf("%d%d",&s[i].a,&s[i].b);
		sort(s,s+n,cmp);
		memset(book,0,sizeof(book));
		for(i=0;i<n-1;i++)
		{
			q=s[i].b;
			if(book[i]==0)
				for(j=i+1;j<n;j++)
				{
					if(book[j]==0&&s[j].b>=q)
					{
						q=s[j].b;
						book[j]=1;
						sum--;
					}
				}
		}
		printf("%d\n",sum);
	}
	return 0;
}
int cmp(data x,data y)
{
	if(x.a!=y.a)
		return x.a<y.a;
	return x.b<y.b;
}